Bug 140423

Summary: r178390 breaks many webgl tests
Product: WebKit Reporter: Roger Fong <roger_fong>
Component: WebGLAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: ap, roger_fong
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on: 140431    
Bug Blocks:    

Description Roger Fong 2015-01-13 19:08:07 PST
http://trac.webkit.org/changeset/178390 broke a lot of WebGL tests
Skipping for now while I fix them.
Comment 1 Alexey Proskuryakov 2015-01-13 23:55:58 PST
Also js/dom/global-constructors-attributes.html broke in a way that doesn't seem expected - we lost existing properties, and we got a seemingly wrong "WebGLRenderingContextBase".

I don't think that it's OK to skip all WebGL tests, and also js/dom/global-constructors-attributes.html too. I'm going to roll out.

@@ -1883,6 +1883,16 @@
 PASS Object.getOwnPropertyDescriptor(global, 'WaveShaperNode').hasOwnProperty('set') is false
 PASS Object.getOwnPropertyDescriptor(global, 'WaveShaperNode').enumerable is false
 PASS Object.getOwnPropertyDescriptor(global, 'WaveShaperNode').configurable is true
+PASS Object.getOwnPropertyDescriptor(global, 'WebGL1RenderingContext').value is WebGL1RenderingContext
+PASS Object.getOwnPropertyDescriptor(global, 'WebGL1RenderingContext').hasOwnProperty('get') is false
+PASS Object.getOwnPropertyDescriptor(global, 'WebGL1RenderingContext').hasOwnProperty('set') is false
+PASS Object.getOwnPropertyDescriptor(global, 'WebGL1RenderingContext').enumerable is false
+PASS Object.getOwnPropertyDescriptor(global, 'WebGL1RenderingContext').configurable is true
+PASS Object.getOwnPropertyDescriptor(global, 'WebGL2RenderingContext').value is WebGL2RenderingContext
+PASS Object.getOwnPropertyDescriptor(global, 'WebGL2RenderingContext').hasOwnProperty('get') is false
+PASS Object.getOwnPropertyDescriptor(global, 'WebGL2RenderingContext').hasOwnProperty('set') is false
+PASS Object.getOwnPropertyDescriptor(global, 'WebGL2RenderingContext').enumerable is false
+PASS Object.getOwnPropertyDescriptor(global, 'WebGL2RenderingContext').configurable is true
 PASS Object.getOwnPropertyDescriptor(global, 'WebGLActiveInfo').value is WebGLActiveInfo
 PASS Object.getOwnPropertyDescriptor(global, 'WebGLActiveInfo').hasOwnProperty('get') is false
 PASS Object.getOwnPropertyDescriptor(global, 'WebGLActiveInfo').hasOwnProperty('set') is false
@@ -1913,11 +1923,11 @@
 PASS Object.getOwnPropertyDescriptor(global, 'WebGLRenderbuffer').hasOwnProperty('set') is false
 PASS Object.getOwnPropertyDescriptor(global, 'WebGLRenderbuffer').enumerable is false
 PASS Object.getOwnPropertyDescriptor(global, 'WebGLRenderbuffer').configurable is true
-PASS Object.getOwnPropertyDescriptor(global, 'WebGLRenderingContext').value is WebGLRenderingContext
-PASS Object.getOwnPropertyDescriptor(global, 'WebGLRenderingContext').hasOwnProperty('get') is false
-PASS Object.getOwnPropertyDescriptor(global, 'WebGLRenderingContext').hasOwnProperty('set') is false
-PASS Object.getOwnPropertyDescriptor(global, 'WebGLRenderingContext').enumerable is false
-PASS Object.getOwnPropertyDescriptor(global, 'WebGLRenderingContext').configurable is true
+PASS Object.getOwnPropertyDescriptor(global, 'WebGLRenderingContextBase').value is WebGLRenderingContextBase
+PASS Object.getOwnPropertyDescriptor(global, 'WebGLRenderingContextBase').hasOwnProperty('get') is false
+PASS Object.getOwnPropertyDescriptor(global, 'WebGLRenderingContextBase').hasOwnProperty('set') is false
+PASS Object.getOwnPropertyDescriptor(global, 'WebGLRenderingContextBase').enumerable is false
+PASS Object.getOwnPropertyDescriptor(global, 'WebGLRenderingContextBase').configurable is true
 PASS Object.getOwnPropertyDescriptor(global, 'WebGLShader').value is WebGLShader
 PASS Object.getOwnPropertyDescriptor(global, 'WebGLShader').hasOwnProperty('get') is false
 PASS Object.getOwnPropertyDescriptor(global, 'WebGLShader').hasOwnProperty('set') is false
Comment 2 Alexey Proskuryakov 2015-01-14 00:07:12 PST

*** This bug has been marked as a duplicate of bug 140431 ***