Bug 140377

Summary: Basic block start offsets should never be larger than end offsets in the control flow profiler
Product: WebKit Reporter: Saam Barati <sbarati>
Component: JavaScriptCoreAssignee: Saam Barati <sbarati>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 138454    
Attachments:
Description Flags
patch
fpizlo: review+
patch (check build) none

Description Saam Barati 2015-01-12 17:03:43 PST
There are a few bugs where a basic block will be created with a start text offset that is larger than its end offset. This is wrong and needs to be fixed.
Comment 1 Saam Barati 2015-01-15 00:26:19 PST
This patch is actually turning into a fix that allows a single textual JavaScript statement to have its AST node instructions emitted multiple times and to not mess up the control flow profiler's computation of basic block boundaries.
Comment 2 Saam Barati 2015-01-15 00:27:35 PST
*** Bug 139287 has been marked as a duplicate of this bug. ***
Comment 3 Saam Barati 2015-01-15 11:35:56 PST
Created attachment 244705 [details]
patch
Comment 4 WebKit Commit Bot 2015-01-15 11:38:34 PST
Attachment 244705 [details] did not pass style-queue:


ERROR: Source/JavaScriptCore/bytecode/CodeBlock.cpp:4082:  Place brace on its own line for function definitions.  [whitespace/braces] [4]
Total errors found: 1 in 7 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 5 Saam Barati 2015-01-19 19:27:37 PST
Created attachment 244952 [details]
patch (check build)

making sure it builds everywhere
Comment 6 WebKit Commit Bot 2015-01-19 19:28:17 PST
Attachment 244952 [details] did not pass style-queue:


ERROR: Source/JavaScriptCore/bytecode/CodeBlock.cpp:4082:  Place brace on its own line for function definitions.  [whitespace/braces] [4]
Total errors found: 1 in 7 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 7 Saam Barati 2015-01-19 20:48:25 PST
landed in:
http://trac.webkit.org/changeset/178692