Bug 140046

Summary: Modernize and streamline HTMLToken and AtomicHTMLToken
Product: WebKit Reporter: Darin Adler <darin>
Component: Page LoadingAssignee: Darin Adler <darin>
Status: RESOLVED FIXED    
Severity: Normal CC: bfulgham, buildbot, commit-queue, dbates, esprehn+autocc, gyuyoung.kim, ossy, rniwa, roger_fong
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch
none
Archive of layout-test-results from ews100 for mac-mountainlion
none
Archive of layout-test-results from ews106 for mac-mountainlion-wk2
none
Patch
none
Patch
none
Patch kling: review+

Description Darin Adler 2015-01-02 13:19:47 PST
Modernize and streamline HTMLToken and AtomicHTMLToken
Comment 1 Darin Adler 2015-01-02 13:34:17 PST
Created attachment 243908 [details]
Patch
Comment 2 Darin Adler 2015-01-04 11:48:17 PST
Created attachment 243932 [details]
Patch
Comment 3 Build Bot 2015-01-04 12:33:35 PST
Comment on attachment 243932 [details]
Patch

Attachment 243932 [details] did not pass mac-ews (mac):
Output: http://webkit-queues.appspot.com/results/6469179959934976

New failing tests:
html5lib/generated/run-tests6-write.html
fast/preloader/first-base-tag-scanned-wins.html
html5lib/generated/run-tests6-data.html
html5lib/generated/run-doctype01-write.html
html5lib/generated/run-doctype01-data.html
fast/preloader/understands-base-tag.html
Comment 4 Build Bot 2015-01-04 12:33:38 PST
Created attachment 243937 [details]
Archive of layout-test-results from ews100 for mac-mountainlion

The attached test failures were seen while running run-webkit-tests on the mac-ews.
Bot: ews100  Port: mac-mountainlion  Platform: Mac OS X 10.8.5
Comment 5 Build Bot 2015-01-04 12:36:59 PST
Comment on attachment 243932 [details]
Patch

Attachment 243932 [details] did not pass mac-wk2-ews (mac-wk2):
Output: http://webkit-queues.appspot.com/results/5813054985994240

New failing tests:
html5lib/generated/run-tests6-write.html
fast/preloader/first-base-tag-scanned-wins.html
html5lib/generated/run-tests6-data.html
html5lib/generated/run-doctype01-write.html
html5lib/generated/run-doctype01-data.html
fast/preloader/understands-base-tag.html
Comment 6 Build Bot 2015-01-04 12:37:02 PST
Created attachment 243939 [details]
Archive of layout-test-results from ews106 for mac-mountainlion-wk2

The attached test failures were seen while running run-webkit-tests on the mac-wk2-ews.
Bot: ews106  Port: mac-mountainlion-wk2  Platform: Mac OS X 10.8.5
Comment 7 Darin Adler 2015-01-04 15:40:06 PST
Created attachment 243943 [details]
Patch
Comment 8 Darin Adler 2015-01-04 16:24:44 PST
This patch is now ready for review. The failures on the Mac and Mac-WK2 bots are a problem unrelated to this patch that I believe Antti has just fixed.
Comment 9 Darin Adler 2015-01-05 00:36:31 PST
Created attachment 243966 [details]
Patch
Comment 10 Darin Adler 2015-01-05 09:34:52 PST
Created attachment 243979 [details]
Patch
Comment 11 Andreas Kling 2015-01-05 10:34:15 PST
Comment on attachment 243979 [details]
Patch

r=me
Comment 12 Darin Adler 2015-01-06 00:06:10 PST
Committed r177952: <http://trac.webkit.org/changeset/177952>
Comment 13 Csaba Osztrogon√°c 2015-01-06 03:25:54 PST
*** Bug 140120 has been marked as a duplicate of this bug. ***
Comment 14 Csaba Osztrogon√°c 2015-01-06 08:30:28 PST
(In reply to comment #12)
> Committed r177952: <http://trac.webkit.org/changeset/177952>

It broke the Apple Windows build:
    1>c:\cygwin\home\buildbot\slave\win-release\build\source\webcore\html\parser\HTMLToken.h(387): error C3083: '{ctor}': the symbol to the left of a '::' must be a type (..\loader\TextResourceDecoder.cpp)
     1>c:\cygwin\home\buildbot\slave\win-release\build\source\webcore\html\parser\HTMLToken.h(388): error C2533: 'WebCore::HTMLToken::appendToAttributeValue' : constructors not allowed a return type (..\loader\TextResourceDecoder.cpp)
     1>c:\cygwin\home\buildbot\slave\win-release\build\source\webcore\html\parser\HTMLToken.h(395): error C3083: '{ctor}': the symbol to the left of a '::' must be a type (..\loader\TextResourceDecoder.cpp)
     1>c:\cygwin\home\buildbot\slave\win-release\build\source\webcore\html\parser\HTMLToken.h(396): error C2533: 'WebCore::HTMLToken::appendToAttributeValue' : constructors not allowed a return type (..\loader\TextResourceDecoder.cpp)


But unfortunately you didn't have any chance to notice it before landing,
because the Windows EWS didn't work since 2.5 weeks. Additionally you
didn't have any chance to notice it after landing, because Anders broke
the Windows build (bug140103) and nobody fixed it yet.
Comment 15 Brent Fulgham 2015-01-06 08:58:15 PST
(In reply to comment #14)

> But unfortunately you didn't have any chance to notice it before landing,
> because the Windows EWS didn't work since 2.5 weeks. Additionally you
> didn't have any chance to notice it after landing, because Anders broke
> the Windows build (bug140103) and nobody fixed it yet.

Windows EWS bots are back up and working now, but they are currently failing to process patches due to the build errors you mentioned.

I've fixed anders' build error (this morning), and will take a look at this new build failure now.
Comment 16 Brent Fulgham 2015-01-06 09:02:10 PST
Comment on attachment 243979 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=243979&action=review

> Source/WebCore/html/parser/HTMLToken.h:387
> +inline void HTMLToken::HTMLToken::appendToAttributeValue(UChar character)

MSVC chokes on this syntax. It wants HTMLToken::appendToAttributeValue.

> Source/WebCore/html/parser/HTMLToken.h:395
> +inline void HTMLToken::HTMLToken::appendToAttributeValue(unsigned i, StringView value)

Ditto above -- MSVC rejects the use of HTMLToken::HTMLToken::{name}
Comment 17 Darin Adler 2015-01-06 10:55:54 PST
Oops! Thanks for fixing that.