Bug 139884

Summary: [Mac WK2] Test snapshots are 1600x1200 on Retina devices
Product: WebKit Reporter: Alexey Proskuryakov <ap>
Component: Tools / TestsAssignee: Alexey Proskuryakov <ap>
Status: RESOLVED FIXED    
Severity: Normal CC: bjonesbe, simon.fraser, thorton, zalan
Priority: P2 Keywords: InRadar
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
See Also: https://bugs.webkit.org/show_bug.cgi?id=142630
https://bugs.webkit.org/show_bug.cgi?id=142632
Attachments:
Description Flags
proposed fix
ap: review-
proposed patch thorton: review+

Description Alexey Proskuryakov 2014-12-22 16:41:37 PST
Pixel tests fail all over the place on OS X 10.10 because the generated results are 1600x1200 instead of 800x600.

Bots don't catch this, because they don't have Retina screens.

rdar://problem/19179429
Comment 1 Alexey Proskuryakov 2014-12-22 16:44:38 PST
Created attachment 243648 [details]
proposed fix
Comment 2 Alexey Proskuryakov 2014-12-22 16:46:41 PST
Comment on attachment 243648 [details]
proposed fix

Looks like this isn't right, I'm told that hidpi tests on Yosemite become broken.
Comment 3 Alexey Proskuryakov 2015-01-06 16:57:23 PST
*** Bug 140125 has been marked as a duplicate of this bug. ***
Comment 4 Alexey Proskuryakov 2015-01-07 12:44:48 PST
Created attachment 244176 [details]
proposed patch
Comment 5 Alexey Proskuryakov 2015-01-08 16:54:47 PST
Committed <http://trac.webkit.org/r178146>.