Bug 13971

Summary: text-anchor support on vertical text seems slightly off (shifted down a little)
Product: WebKit Reporter: Eric Seidel (no email) <eric>
Component: SVGAssignee: Nikolas Zimmermann <zimmermann>
Status: RESOLVED DUPLICATE    
Severity: Normal    
Priority: P2    
Version: 523.x (Safari 3)   
Hardware: Mac   
OS: OS X 10.4   
URL: http://www.w3.org/Graphics/SVG/Test/20061213/htmlEmbedHarness/full-text-align-05-b.html
Attachments:
Description Flags
screenie none

Description Eric Seidel (no email) 2007-06-01 14:40:17 PDT
text-anchor support on vertical text seems slightly off (shifted down a little)

See referenced test case.
Comment 1 Eric Seidel (no email) 2007-06-01 14:41:02 PDT
Created attachment 14833 [details]
screenie
Comment 2 Rob Buis 2007-06-11 17:25:46 PDT
We're going to fix this by having Niko break out the glyph height logic into platform specific code, and then we'll let one of the various platform font experts build working solution.
Comment 3 Nikolas Zimmermann 2007-11-10 16:02:04 PST
It turned out, that it's actually a bug in our text engine - fixing it right now.
Comment 4 Nikolas Zimmermann 2007-11-10 17:38:32 PST

*** This bug has been marked as a duplicate of 15937 ***