Bug 13800

Summary: REGRESSION: Moving a slider moves another unrelated slider
Product: WebKit Reporter: mitz
Component: FormsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: adele
Priority: P1 Keywords: Regression
Version: 523.x (Safari 3)   
Hardware: Mac   
OS: OS X 10.4   
Attachments:
Description Flags
Test case
none
Avoid sharing the thumb style darin: review+

Description mitz 2007-05-21 12:54:27 PDT
In the attached test case, one slider has an oninput handler that changes the style of another element. Strangely, this has two side effects:
1) The thumb's initial position ignores the value attribute.
2) Moving the slider's thumb moves a second, unrelated, slider's thumb along with it.
Comment 1 mitz 2007-05-21 12:55:15 PDT
Created attachment 14644 [details]
Test case
Comment 2 mitz 2007-05-22 05:11:14 PDT
I think this is caused by style sharing between the two sliders' thumbs.
Comment 3 mitz 2007-05-22 05:51:27 PDT
Created attachment 14653 [details]
Avoid sharing the thumb style
Comment 4 Darin Adler 2007-05-22 10:00:23 PDT
Comment on attachment 14653 [details]
Avoid sharing the thumb style

r=me
Comment 5 Sam Weinig 2007-05-24 17:15:41 PDT
Landed in r21739