Bug 137618

Summary: REGRESSION(r174540) [GTK] Layout test mathml/opentype/horizontal.html fails
Product: WebKit Reporter: Carlos Alberto Lopez Perez <clopez>
Component: Tools / TestsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: darin, sabouhallawa
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   

Description Carlos Alberto Lopez Perez 2014-10-10 11:26:06 PDT
mathml/opentype/horizontal.html is failing on GTK since r174540 <http://trac.webkit.org/r174540>

Regressions: Unexpected text-only failures (1)
  mathml/opentype/horizontal.html [ Failure ]


The diff is: https://build.webkit.org/results/GTK%20Linux%2064-bit%20Release%20%28Tests%29/r174601%20%283403%29/mathml/opentype/horizontal-pretty-diff.html


Maybe it needs just to be rebaselined? I'm asking because r174540 didn't touched or rebaselined this test for Mac or other port. So I'm not sure if this is a real failure or it just needs to be rebaselined. This is what the GTK MiniBrowser renders: http://people.igalia.com/clopez/opentype-horizontal.jpg
Comment 1 Carlos Alberto Lopez Perez 2014-10-10 11:38:13 PDT
BTW, on https://trac.webkit.org/r174605 I rebaselined for the GTK port this other two tests

  mathml/opentype/munderover-window-resize.html
  mathml/opentype/opentype-stretchy-horizontal.html


Since that both tests were also updated for the mac port on r174540, and the diffs where coherent (pixel sizes only) I guessed that rebaselining them is correct.
Comment 2 Said Abou-Hallawa 2014-10-10 12:53:22 PDT
(In reply to comment #0)
> mathml/opentype/horizontal.html is failing on GTK since r174540 <http://trac.webkit.org/r174540>
> 
> Regressions: Unexpected text-only failures (1)
>   mathml/opentype/horizontal.html [ Failure ]
> 
> 
> The diff is: https://build.webkit.org/results/GTK%20Linux%2064-bit%20Release%20%28Tests%29/r174601%20%283403%29/mathml/opentype/horizontal-pretty-diff.html
> 
> 
> Maybe it needs just to be rebaselined? I'm asking because r174540 didn't touched or rebaselined this test for Mac or other port. So I'm not sure if this is a real failure or it just needs to be rebaselined. This is what the GTK MiniBrowser renders: http://people.igalia.com/clopez/opentype-horizontal.jpg

I did not rebaseline them because they are excluded from the mac test suite. In the file LayoutTests/platform/mac/TestExpectations, these lines are there:

webkit.org/b/72828 mathml/opentype/horizontal.html [ Failure ]
webkit.org/b/72828 mathml/opentype/horizontal-munderover.html [ Failure ]

# Missing references
webkit.org/b/119038 mathml/presentation/mo-stretch.html [ Failure ]
webkit.org/b/119038 mathml/presentation/roots.xhtml [ Failure ]

So I think for GTK, it is safe to rebaseline all the MathML tests which are failing because of munderover object layout and which are expected to fail on Mac.  For Mac we need to do the same but maybe when these tests are expected to succeed.
Comment 3 Carlos Alberto Lopez Perez 2014-10-14 10:26:06 PDT
(In reply to comment #2)
> (In reply to comment #0)
> > mathml/opentype/horizontal.html is failing on GTK since r174540 <http://trac.webkit.org/r174540>
> > 
> > Regressions: Unexpected text-only failures (1)
> >   mathml/opentype/horizontal.html [ Failure ]
> > 
> > 
> > The diff is: https://build.webkit.org/results/GTK%20Linux%2064-bit%20Release%20%28Tests%29/r174601%20%283403%29/mathml/opentype/horizontal-pretty-diff.html
> > 
> > 
> > Maybe it needs just to be rebaselined? I'm asking because r174540 didn't touched or rebaselined this test for Mac or other port. So I'm not sure if this is a real failure or it just needs to be rebaselined. This is what the GTK MiniBrowser renders: http://people.igalia.com/clopez/opentype-horizontal.jpg
> 
> I did not rebaseline them because they are excluded from the mac test suite. In the file LayoutTests/platform/mac/TestExpectations, these lines are there:
> 
> webkit.org/b/72828 mathml/opentype/horizontal.html [ Failure ]
> webkit.org/b/72828 mathml/opentype/horizontal-munderover.html [ Failure ]
> 
> # Missing references
> webkit.org/b/119038 mathml/presentation/mo-stretch.html [ Failure ]
> webkit.org/b/119038 mathml/presentation/roots.xhtml [ Failure ]
> 
> So I think for GTK, it is safe to rebaseline all the MathML tests which are failing because of munderover object layout and which are expected to fail on Mac.  For Mac we need to do the same but maybe when these tests are expected to succeed.

I have rebaselined the test for GTK on r174685 <http://trac.webkit.org/r174685>

Thanks for your help.

Closing the bug.