Bug 137143

Summary: [EFL] Bump up dependencies not to conflict with the GTK port.
Product: WebKit Reporter: Akos Kiss <akiss>
Component: Tools / TestsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue, gyuyoung.kim, ossy, ryuan.choi
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Proposed patch. none

Description Akos Kiss 2014-09-26 00:21:47 PDT
Tools/efl/install-dependencies and Tools/gtk/install-dependencies keep installing and removing different versions of libgnutls-dev, thus hindering the development for both ports on the same machine.
Comment 1 Akos Kiss 2014-09-26 00:26:07 PDT
Created attachment 238703 [details]
Proposed patch.
Comment 2 Csaba Osztrogon√°c 2014-09-26 00:30:37 PDT
Comment on attachment 238703 [details]
Proposed patch.

LGTM if it is suitable for the EFL maintainers,
so I let the final review for Gyuyoung.
Comment 3 Gyuyoung Kim 2014-09-26 00:40:12 PDT
Comment on attachment 238703 [details]
Proposed patch.

I already talked with Akos for this issue. EFL port needs to follow libgnutls library because EFL port is using libsoup as network backend as well. I install libgnutls28-dev to EFL buildbot and ews bots.
Comment 4 WebKit Commit Bot 2014-09-26 01:20:50 PDT
Comment on attachment 238703 [details]
Proposed patch.

Clearing flags on attachment: 238703

Committed r174001: <http://trac.webkit.org/changeset/174001>
Comment 5 WebKit Commit Bot 2014-09-26 01:20:55 PDT
All reviewed patches have been landed.  Closing bug.