Bug 136946

Summary: REGRESSION(r173631): It broke the !ENABLE(VIDEO) build
Product: WebKit Reporter: Csaba Osztrogonác <ossy>
Component: New BugsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue, evab.u-szeged, jer.noble, ossy, simon.fraser
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 136837    
Attachments:
Description Flags
Patch
none
Patch none

Description Csaba Osztrogonác 2014-09-19 02:22:39 PDT
build log:
/home/webkit/WebKit/Source/WebCore/page/DragController.cpp: In member function 'bool WebCore::DragController::startDrag(WebCore::Frame&, const WebCore::DragState&, WebCore::DragOperation, const WebCore::PlatformMouseEvent&, const WebCore::IntPoint&)':
/home/webkit/WebKit/Source/WebCore/page/DragController.cpp:726:43: error: 'class WebCore::Element' has no member named 'isMediaElement'
Comment 1 Éva Balázsfalvi 2014-09-19 03:47:25 PDT
Created attachment 238369 [details]
Patch
Comment 2 Simon Fraser (smfr) 2014-09-19 08:50:31 PDT
Comment on attachment 238369 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=238369&action=review

> Source/WebCore/page/DragController.cpp:726
> +    bool includeShadowDOM = true;

Shouldn't this default to false?
Comment 3 Éva Balázsfalvi 2014-09-22 04:14:08 PDT
Created attachment 238476 [details]
Patch
Comment 4 WebKit Commit Bot 2014-09-22 08:01:04 PDT
Comment on attachment 238476 [details]
Patch

Clearing flags on attachment: 238476

Committed r173836: <http://trac.webkit.org/changeset/173836>
Comment 5 WebKit Commit Bot 2014-09-22 08:01:08 PDT
All reviewed patches have been landed.  Closing bug.