Bug 136940

Summary: ASSERTION FAILED: tracks[i].m_maxBreadth != infinity in WebCore::RenderGrid::computeUsedBreadthOfGridTracks
Product: WebKit Reporter: Renata Hodovan <rhodovan.u-szeged>
Component: Layout and RenderingAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: jfernandez, rego, svillar
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on: 136575    
Bug Blocks: 116980    
Attachments:
Description Flags
Test case none

Description Renata Hodovan 2014-09-19 01:25:14 PDT
Created attachment 238356 [details]
Test case

The following test results in the assertion failure:

<!DOCTYPE html>
<style>
*  {
    display: -webkit-inline-grid;
    -webkit-grid-auto-rows: minmax(100%, -webkit-min-content);
}
</style>

It's probably the same issue as http://crbug.com/401477.


The backtrace:

ASSERTION FAILED: tracks[i].m_maxBreadth != infinity
../../Source/WebCore/rendering/RenderGrid.cpp(323) : void WebCore::RenderGrid::computeUsedBreadthOfGridTracks(WebCore::GridTrackSizingDirection, WebCore::RenderGrid::GridSizingData&, WebCore::LayoutUnit&)

0x00007fffedbf3127 in WTFCrash () at ../../Source/WTF/wtf/Assertions.cpp:329
329	    *(int *)(uintptr_t)0xbbadbeef = 0;
#0  0x00007fffedbf3127 in WTFCrash () at ../../Source/WTF/wtf/Assertions.cpp:329
#1  0x00007ffff3a04df1 in WebCore::RenderGrid::computeUsedBreadthOfGridTracks (this=0x94f510, direction=WebCore::ForRows, sizingData=..., availableLogicalSpace=...) at ../../Source/WebCore/rendering/RenderGrid.cpp:323
#2  0x00007ffff3a04b31 in WebCore::RenderGrid::computeUsedBreadthOfGridTracks (this=0x94f510, direction=WebCore::ForRows, sizingData=...) at ../../Source/WebCore/rendering/RenderGrid.cpp:286
#3  0x00007ffff3a086f7 in WebCore::RenderGrid::layoutGridItems (this=0x94f510) at ../../Source/WebCore/rendering/RenderGrid.cpp:883
#4  0x00007ffff3a046f0 in WebCore::RenderGrid::layoutBlock (this=0x94f510, relayoutChildren=0x0) at ../../Source/WebCore/rendering/RenderGrid.cpp:218
#5  0x00007ffff392285f in WebCore::RenderBlock::layout (this=0x94f510) at ../../Source/WebCore/rendering/RenderBlock.cpp:1019
#6  0x00007ffff38ed18f in WebCore::RenderElement::layoutIfNeeded (this=0x94f510) at ../../Source/WebCore/rendering/RenderElement.h:102
#7  0x00007ffff3a05e97 in WebCore::RenderGrid::logicalContentHeightForChild (this=0x80c8a0, child=..., columnTracks=...) at ../../Source/WebCore/rendering/RenderGrid.cpp:498
#8  0x00007ffff3a05f92 in WebCore::RenderGrid::minContentForChild (this=0x80c8a0, child=..., direction=WebCore::ForRows, columnTracks=...) at ../../Source/WebCore/rendering/RenderGrid.cpp:515
#9  0x00007ffff3a068d5 in WebCore::RenderGrid::resolveContentBasedTrackSizingFunctionsForItems (this=0x80c8a0, direction=WebCore::ForRows, sizingData=..., gridItemWithSpan=..., filterFunction=(bool (WebCore::GridTrackSize::*)(const WebCore::GridTrackSize * const)) 0x7ffff3a09fea <WebCore::GridTrackSize::hasMinOrMaxContentMaxTrackBreadth() const>, sizingFunction=(WebCore::LayoutUnit (WebCore::RenderGrid::*)(WebCore::RenderGrid * const, WebCore::RenderBox &, WebCore::GridTrackSizingDirection, WTF::Vector<WebCore::GridTrack, 0ul, WTF::CrashOnOverflow> &)) 0x7ffff3a05ed8 <WebCore::RenderGrid::minContentForChild(WebCore::RenderBox&, WebCore::GridTrackSizingDirection, WTF::Vector<WebCore::GridTrack, 0ul, WTF::CrashOnOverflow>&)>, trackGetter=(WebCore::LayoutUnit (WebCore::GridTrack::*)(const WebCore::GridTrack * const)) 0x7ffff3a0a43a <WebCore::GridTrack::maxBreadthIfNotInfinite() const>, trackGrowthFunction=(void (WebCore::GridTrack::*)(WebCore::GridTrack * const, WebCore::LayoutUnit)) 0x7ffff3a0a3d6 <WebCore::GridTrack::growMaxBreadth(WebCore::LayoutUnit)>) at ../../Source/WebCore/rendering/RenderGrid.cpp:605
#10 0x00007ffff3a06491 in WebCore::RenderGrid::resolveContentBasedTrackSizingFunctions (this=0x80c8a0, direction=WebCore::ForRows, sizingData=...) at ../../Source/WebCore/rendering/RenderGrid.cpp:576
#11 0x00007ffff3a04d8c in WebCore::RenderGrid::computeUsedBreadthOfGridTracks (this=0x80c8a0, direction=WebCore::ForRows, sizingData=..., availableLogicalSpace=...) at ../../Source/WebCore/rendering/RenderGrid.cpp:320
#12 0x00007ffff3a04b31 in WebCore::RenderGrid::computeUsedBreadthOfGridTracks (this=0x80c8a0, direction=WebCore::ForRows, sizingData=...) at ../../Source/WebCore/rendering/RenderGrid.cpp:286
#13 0x00007ffff3a086f7 in WebCore::RenderGrid::layoutGridItems (this=0x80c8a0) at ../../Source/WebCore/rendering/RenderGrid.cpp:883
#14 0x00007ffff3a046f0 in WebCore::RenderGrid::layoutBlock (this=0x80c8a0, relayoutChildren=0x0) at ../../Source/WebCore/rendering/RenderGrid.cpp:218
#15 0x00007ffff392285f in WebCore::RenderBlock::layout (this=0x80c8a0) at ../../Source/WebCore/rendering/RenderBlock.cpp:1019
#16 0x00007ffff394e6b0 in WebCore::RenderBlockFlow::layoutBlockChild (this=0x81e6e0, child=..., marginInfo=..., previousFloatLogicalBottom=..., maxFloatLogicalBottom=...) at ../../Source/WebCore/rendering/RenderBlockFlow.cpp:712
#17 0x00007ffff394e1d1 in WebCore::RenderBlockFlow::layoutBlockChildren (this=0x81e6e0, relayoutChildren=0x1, maxFloatLogicalBottom=...) at ../../Source/WebCore/rendering/RenderBlockFlow.cpp:633
#18 0x00007ffff394d5ee in WebCore::RenderBlockFlow::layoutBlock (this=0x81e6e0, relayoutChildren=0x1, pageLogicalHeight=...) at ../../Source/WebCore/rendering/RenderBlockFlow.cpp:486
#19 0x00007ffff392285f in WebCore::RenderBlock::layout (this=0x81e6e0) at ../../Source/WebCore/rendering/RenderBlock.cpp:1019
#20 0x00007ffff3b1aaa9 in WebCore::RenderView::layoutContent (this=0x81e6e0, state=...) at ../../Source/WebCore/rendering/RenderView.cpp:230
#21 0x00007ffff3b1b179 in WebCore::RenderView::layout (this=0x81e6e0) at ../../Source/WebCore/rendering/RenderView.cpp:355
#22 0x00007ffff369240f in WebCore::FrameView::layout (this=0x85a990, allowSubtree=0x1) at ../../Source/WebCore/page/FrameView.cpp:1301
#23 0x00007ffff30613d5 in WebCore::Document::implicitClose (this=0xa461e0) at ../../Source/WebCore/dom/Document.cpp:2441
#24 0x00007ffff3540b63 in WebCore::FrameLoader::checkCallImplicitClose (this=0x88c648) at ../../Source/WebCore/loader/FrameLoader.cpp:898
#25 0x00007ffff35408cb in WebCore::FrameLoader::checkCompleted (this=0x88c648) at ../../Source/WebCore/loader/FrameLoader.cpp:844
#26 0x00007ffff3540634 in WebCore::FrameLoader::finishedParsing (this=0x88c648) at ../../Source/WebCore/loader/FrameLoader.cpp:764
#27 0x00007ffff3069e57 in WebCore::Document::finishedParsing (this=0xa461e0) at ../../Source/WebCore/dom/Document.cpp:4524
#28 0x00007ffff33bd667 in WebCore::HTMLConstructionSite::finishedParsing (this=0xac1918) at ../../Source/WebCore/html/parser/HTMLConstructionSite.cpp:395
#29 0x00007ffff33fb1dd in WebCore::HTMLTreeBuilder::finished (this=0xac1900) at ../../Source/WebCore/html/parser/HTMLTreeBuilder.cpp:2997
#30 0x00007ffff33c60d0 in WebCore::HTMLDocumentParser::end (this=0x9609e0) at ../../Source/WebCore/html/parser/HTMLDocumentParser.cpp:439
#31 0x00007ffff33c61bb in WebCore::HTMLDocumentParser::attemptToRunDeferredScriptsAndEnd (this=0x9609e0) at ../../Source/WebCore/html/parser/HTMLDocumentParser.cpp:450
#32 0x00007ffff33c4c69 in WebCore::HTMLDocumentParser::prepareToStopParsing (this=0x9609e0) at ../../Source/WebCore/html/parser/HTMLDocumentParser.cpp:165
#33 0x00007ffff33c61fe in WebCore::HTMLDocumentParser::attemptToEnd (this=0x9609e0) at ../../Source/WebCore/html/parser/HTMLDocumentParser.cpp:462
#34 0x00007ffff33c62b5 in WebCore::HTMLDocumentParser::finish (this=0x9609e0) at ../../Source/WebCore/html/parser/HTMLDocumentParser.cpp:490
#35 0x00007ffff35322d1 in WebCore::DocumentWriter::end (this=0x949a00) at ../../Source/WebCore/loader/DocumentWriter.cpp:246
#36 0x00007ffff351d9ad in WebCore::DocumentLoader::finishedLoading (this=0x949960, finishTime=0) at ../../Source/WebCore/loader/DocumentLoader.cpp:441
#37 0x00007ffff351d716 in WebCore::DocumentLoader::notifyFinished (this=0x949960, resource=0x8a7920) at ../../Source/WebCore/loader/DocumentLoader.cpp:375
#38 0x00007ffff35d47c4 in WebCore::CachedResource::checkNotify (this=0x8a7920) at ../../Source/WebCore/loader/cache/CachedResource.cpp:347
#39 0x00007ffff35d48ce in WebCore::CachedResource::finishLoading (this=0x8a7920) at ../../Source/WebCore/loader/cache/CachedResource.cpp:363
#40 0x00007ffff35d11f4 in WebCore::CachedRawResource::finishLoading (this=0x8a7920, data=0x8a89c0) at ../../Source/WebCore/loader/cache/CachedRawResource.cpp:101
#41 0x00007ffff3580a50 in WebCore::SubresourceLoader::didFinishLoading (this=0x8a7e90, finishTime=0) at ../../Source/WebCore/loader/SubresourceLoader.cpp:309
#42 0x00007ffff357c73b in WebCore::ResourceLoader::didFinishLoading (this=0x8a7e90, finishTime=0) at ../../Source/WebCore/loader/ResourceLoader.cpp:512
#43 0x00007ffff3eecb0f in WebCore::readCallback (asyncResult=0x81d1a0, data=0x8a54a0) at ../../Source/WebCore/platform/network/soup/ResourceHandleSoup.cpp:1302
#44 0x00007fffebac72ea in async_ready_callback_wrapper (source_object=0xa3bb30, res=0x81d1a0, user_data=0x8a54a0) at ginputstream.c:519
#45 0x00007fffebae6ceb in g_task_return_now (task=0x81d1a0) at gtask.c:1108
#46 0x00007fffebae6d09 in complete_in_idle_cb (task=0x81d1a0) at gtask.c:1117
#47 0x00007fffead3d2e6 in g_main_dispatch (context=0x677bb0) at gmain.c:3065
#48 g_main_context_dispatch (context=context@entry=0x677bb0) at gmain.c:3641
#49 0x00007fffead3d638 in g_main_context_iterate (context=0x677bb0, block=block@entry=0x1, dispatch=dispatch@entry=0x1, self=<optimized out>) at gmain.c:3712
#50 0x00007fffead3da3a in g_main_loop_run (loop=0xafe450) at gmain.c:3906
#51 0x00007ffff45e062e in WTF::RunLoop::run () at ../../Source/WTF/wtf/gtk/RunLoopGtk.cpp:59
#52 0x00007ffff2b1c1e2 in WebKit::ChildProcessMain<WebKit::WebProcess, WebKit::WebProcessMain> (argc=0x2, argv=0x7fffffffd938) at ../../Source/WebKit2/Shared/unix/ChildProcessMain.h:61
#53 0x00007ffff2b1c047 in WebKit::WebProcessMainUnix (argc=0x2, argv=0x7fffffffd938) at ../../Source/WebKit2/WebProcess/gtk/WebProcessMainGtk.cpp:73
#54 0x000000000040080d in main (argc=0x2, argv=0x7fffffffd938) at ../../Source/WebKit2/WebProcess/EntryPoint/unix/WebProcessMain.cpp:32
Comment 1 Sergio Villar Senin 2014-09-19 08:18:12 PDT
I have a patch that fixes this issue but I need 136575 to land first.
Comment 2 Sergio Villar Senin 2014-09-23 07:15:13 PDT
Already addressed in another bug with an available patch.

*** This bug has been marked as a duplicate of bug 136453 ***