Bug 136832

Summary: [GTK] Add Wayland support to LayerTreeHostGtk
Product: WebKit Reporter: Zan Dobersek <zan>
Component: New BugsAssignee: Zan Dobersek <zan>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: cgarcia, commit-queue, mcatanzaro, mrobinson
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on: 136849    
Bug Blocks:    
Attachments:
Description Flags
Patch
none
Patch
none
Patch
none
Patch none

Description Zan Dobersek 2014-09-15 13:23:58 PDT
[GTK] Add Wayland support to LayerTreeHostGtk
Comment 1 Zan Dobersek 2014-09-15 13:29:39 PDT
Created attachment 238139 [details]
Patch
Comment 2 WebKit Commit Bot 2014-09-15 13:32:45 PDT
Attachment 238139 [details] did not pass style-queue:


ERROR: Source/WebKit2/WebProcess/WebPage/gtk/LayerTreeHostGtk.cpp:75:  enum members should use InterCaps with an initial capital letter.  [readability/enum_casing] [4]
Total errors found: 1 in 3 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Zan Dobersek 2014-09-16 02:48:15 PDT
Created attachment 238167 [details]
Patch
Comment 4 Zan Dobersek 2014-09-16 13:34:36 PDT
Created attachment 238200 [details]
Patch
Comment 5 Zan Dobersek 2014-09-17 05:45:45 PDT
Created attachment 238250 [details]
Patch
Comment 6 Michael Catanzaro 2016-01-06 20:12:12 PST
Comment on attachment 238250 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=238250&action=review

Looks sane.

> Source/WebKit2/WebProcess/WebPage/gtk/LayerTreeHostGtk.cpp:93
> +    if (getDisplaySystemType() == DisplaySystemType::X11) {

This need updated to use PlatformDisplay?

> Source/WebKit2/WebProcess/WebPage/gtk/LayerTreeHostGtk.cpp:96
> +            return 0;

Change it to nullptr.
Comment 7 Michael Catanzaro 2016-01-06 20:14:03 PST
Eh, wait for Martin, he was planning to update and handle these.
Comment 8 Michael Catanzaro 2016-01-14 14:01:36 PST
Comment on attachment 238250 [details]
Patch

Martin says this needs more work.
Comment 9 Carlos Garcia Campos 2016-08-17 00:32:06 PDT
Let's track this in bug #115803 instead.

*** This bug has been marked as a duplicate of bug 115803 ***