Bug 135674

Summary: Web Inspector: DebuggerManager sends spurious setBreakpointsActive commands when setting a breakpoint
Product: WebKit Reporter: Brian Burg <burg>
Component: Web InspectorAssignee: Brian Burg <burg>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue, graouts, joepeck, timothy, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Attachments:
Description Flags
partial protocol dump
none
Patch none

Description Brian Burg 2014-08-06 15:37:12 PDT
Created attachment 236145 [details]
partial protocol dump

For every Debugger.setBreakpoint command, we also send Debugger.setBreakpointsActive and Debugger.setPauseOnExceptions commands, even if nothing changed. This adds a lot of useless messages in the initialization sequence, and for all further breakpoint sets.
Comment 1 Radar WebKit Bug Importer 2014-08-06 15:37:22 PDT
<rdar://problem/17937991>
Comment 2 Brian Burg 2014-08-07 10:05:06 PDT
Created attachment 236193 [details]
Patch
Comment 3 Brian Burg 2014-08-07 10:14:45 PDT
Turns out it was just a typo.
Comment 4 David Kilzer (:ddkilzer) 2014-08-07 10:25:40 PDT
Comment on attachment 236193 [details]
Patch

r=me
Comment 5 WebKit Commit Bot 2014-08-07 10:58:08 PDT
Comment on attachment 236193 [details]
Patch

Clearing flags on attachment: 236193

Committed r172217: <http://trac.webkit.org/changeset/172217>
Comment 6 WebKit Commit Bot 2014-08-07 10:58:10 PDT
All reviewed patches have been landed.  Closing bug.