Bug 135656

Summary: REGRESSION: Inspector crashes when debugger is paused and injected scripts access window.screen()
Product: WebKit Reporter: Brian Burg <burg>
Component: JavaScriptCoreAssignee: Mark Lam <mark.lam>
Status: RESOLVED FIXED    
Severity: Normal CC: fpizlo, ggaren, joepeck, mark.lam, sbarati, timothy, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
CrashReporter dump none

Description Brian Burg 2014-08-06 10:33:24 PDT
Created attachment 236109 [details]
CrashReporter dump

This did not happen as of yesterday on trunk. It's reproducible on my machine, at least.

1. Go to a website (eg., http://www.nihilogic.dk/labs/tetris/)
2. Set breakpoint (eg., tetris.js:95)
3. Hit the breakpoint (eg., press any key)
4. *boom*
Comment 1 Radar WebKit Bug Importer 2014-08-06 10:45:44 PDT
<rdar://problem/17933210>
Comment 2 Mark Lam 2014-08-08 15:40:37 PDT
The regression was introduced in <http://trac.webkit.org/r172129> which is a mega merge commit.  Proceeding with teasing out the individual merge revision that is the culprit.
Comment 3 Mark Lam 2014-08-08 23:48:58 PDT
The issue is due r170680: <http://trac.webkit.org/r170680> which was merged in r172129.  Will roll out the patch for now while I figure out what the root issue is, and re-open https://bugs.webkit.org/show_bug.cgi?id=134420 to do the real work.
Comment 4 Mark Lam 2014-08-08 23:51:37 PDT
Patch for r170680 rolled out in r172372: <http://trac.webkit.org/r172372>.