Bug 13403

Summary: REGRESSION (r18875-r18899): Can no longer type into search form field after searching and then clicking "back"
Product: WebKit Reporter: David Glover <wk@davidglover.org>
Component: FormsAssignee: mitz@webkit.org <mitz@webkit.org>
Status: RESOLVED FIXED    
Severity: Major CC: adele@apple.com, mitz@webkit.org, mrowe@apple.com
Priority: P1 Keywords: NeedsRadar, NeedsReduction, Regression
Version: 523.x (Safari 3)   
Hardware: Macintosh   
OS: Mac OS X 10.4   
URL: http://www.apple.com/downloads/macosx/
Attachments:
Description Flags
Patch darin: review+

Description From 2007-04-19 07:13:53 PST
1. Go to http://www.apple.com/downloads/macosx/
2. Type something into the search box in the top left and press Return. (I searched for "rss".)
3. Click the Back button.
4. Try to edit the contents of the search box.

Result: You can delete characters, but you can't type new characters.

This is not reproduced in 419.3.
------- Comment #1 From 2007-04-19 10:18:34 PST -------
David,

"419.x" is the release version of Safari, and "522+" is all recent WebKit nightlies.  

Could you give us more information such as which WebKit nightly you were using when you saw that it was broken?  
Also it is often valuable to download some of the older WebKit nightlies to discover when this broke.

Thanks!
------- Comment #2 From 2007-04-19 10:24:35 PST -------
I was using today's (April 19 2007) nightly.
------- Comment #3 From 2007-04-19 10:25:45 PST -------
This is specific to this particular page, and doesn't happen on other pages.

I'm pretty sure it's due to some JavaScript on the page that's trapping the key down events.
------- Comment #4 From 2007-04-19 10:29:34 PST -------
(In reply to comment #3)
> This is specific to this particular page, and doesn't happen on other pages.
> 
> I'm pretty sure it's due to some JavaScript on the page that's trapping the key
> down events.
> 

I'm seeing some painting artifacts when I type in the field after back navigation, so I think it's more than that.
------- Comment #5 From 2007-04-19 10:37:11 PST -------
Regressed between r18875 and r18899. My suspect is <http://trac.webkit.org/projects/webkit/changeset/18877>.
------- Comment #6 From 2007-04-19 12:40:55 PST -------
Created an attachment (id=14093) [details]
Patch

I don't know how to make a layout test for this bug.
------- Comment #7 From 2007-04-19 18:50:22 PST -------
(From update of attachment 14093 [details])
r=me
------- Comment #8 From 2007-04-19 19:28:48 PST -------
Landed in r20964.