Bug 133803

Summary: REGRESSION(169799): [GTK] several layout tests on editing/ fail
Product: WebKit Reporter: Carlos Alberto Lopez Perez <clopez>
Component: Tools / TestsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: bugs-noreply, cgarcia, dpino, ltilve, svillar, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   

Comment 1 Carlos Alberto Lopez Perez 2014-06-12 11:40:16 PDT
I added this tests to the GTK TestExpectations on http://webkit.org/b/133811
Comment 2 Carlos Garcia Campos 2014-06-13 01:30:47 PDT
I'm not sure this is a regression, are you sure our own expectation files are correct? The actual result I see for editing/deleting/delete-by-word-001 looks the same than cross-platform expected results. Note that the test does:

    if (navigator.userAgent.search(/\bMac OS X\b/) != -1)
        deleteWordModifiers = ["altKey"];
    else
        deleteWordModifiers = ["ctrlKey"];

So, before r169799 we were using the alt key instead of the control key, which I think was wrong.
Comment 3 Carlos Alberto Lopez Perez 2014-06-13 04:25:20 PDT
(In reply to comment #2)
> I'm not sure this is a regression, are you sure our own expectation files are correct? The actual result I see for editing/deleting/delete-by-word-001 looks the same than cross-platform expected results. Note that the test does:
> 
>     if (navigator.userAgent.search(/\bMac OS X\b/) != -1)
>         deleteWordModifiers = ["altKey"];
>     else
>         deleteWordModifiers = ["ctrlKey"];
> 
> So, before r169799 we were using the alt key instead of the control key, which I think was wrong.

It may be be that the test expectations for this tests before r169799 were wrong.

Lorenzo commented that r169799 made a bunch of tests to pass, so maybe this ones that started to fail just need to be rebaselined.

Compare the results:

169798 -> layout-test 16 failures 13 new passes 23 flakes 1 missing results http://build.webkit.org/builders/GTK%20Linux%2064-bit%20Release%20%28Tests%29/builds/744
169799 -> layout-test 20 failures 21 new passes 15 flakes 1 missing results http://build.webkit.org/builders/GTK%20Linux%2064-bit%20Release%20%28Tests%29/builds/745
Comment 4 Sergio Villar Senin 2014-06-13 08:12:28 PDT
(In reply to comment #3)
> It may be be that the test expectations for this tests before r169799 were wrong.
> 
> Lorenzo commented that r169799 made a bunch of tests to pass, so maybe this ones that started to fail just need to be rebaselined.

Let's rebaseline them and remove as many platform specific results as possible.
Comment 5 Diego Pino 2024-05-28 23:29:18 PDT
The test(s) filed under this bug are consistenly passing since 275882@main (updated baselines for these tests).

https://results.webkit.org/?platform=GTK&platform=WPE&suite=layout-tests&test=editing%2Fdeleting%2Fdelete-by-word-001.html

After updating test expectations in 279290@main, there are no more tests referring to this bug. Closing bug.
Comment 6 Radar WebKit Bug Importer 2024-05-28 23:30:15 PDT
<rdar://problem/128921894>