Bug 133709

Summary: AX: iOS: VoiceOver ignores input type = date in Safari on iOS7
Product: WebKit Reporter: chris fleizach <cfleizach>
Component: AccessibilityAssignee: chris fleizach <cfleizach>
Status: RESOLVED FIXED    
Severity: Normal CC: aboxhall, apinheiro, commit-queue, dmazzoni, james, jcraig, jdiggs, jon.avila, mario, samuel_white, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Attachments:
Description Flags
patch none

Description chris fleizach 2014-06-10 17:35:11 PDT
When using VoiceOver in Safari on iOS 7.0, an HTML INPUT element with type = date with no initial value is completely ignored.

VoiceOver does not provide any feedback to the user that the input field exists, nor is it possible to activate the date picker or input any data into the form field.

<rdar://problem/15733368>
Comment 1 chris fleizach 2014-06-10 17:58:36 PDT
Created attachment 232837 [details]
patch
Comment 2 WebKit Commit Bot 2014-06-11 09:13:27 PDT
Comment on attachment 232837 [details]
patch

Clearing flags on attachment: 232837

Committed r169809: <http://trac.webkit.org/changeset/169809>
Comment 3 WebKit Commit Bot 2014-06-11 09:13:31 PDT
All reviewed patches have been landed.  Closing bug.
Comment 4 chris fleizach 2014-07-03 14:05:05 PDT
*** Bug 134610 has been marked as a duplicate of this bug. ***