Bug 133145

Summary: REGRESSION(r169092): It broke run-jsc-stress tests on non Mac platforms
Product: WebKit Reporter: Csaba Osztrogonác <ossy>
Component: JavaScriptCoreAssignee: Éva Balázsfalvi <evab.u-szeged>
Status: RESOLVED FIXED    
Severity: Blocker CC: clopez, fpizlo, ggaren, ossy
Priority: P1    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Bug Depends on:    
Bug Blocks: 133090    
Attachments:
Description Flags
Patch none

Description Csaba Osztrogonác 2014-05-21 00:59:55 PDT
https://trac.webkit.org/changeset/169092 broke run-jsc-stress tests 
on non Mac platforms, because there isn't otool anywhere except on Mac.

Here is the exception from EFL and GTK bots:

Tools/Scripts/run-jsc-stress-tests:181:in ``': No such file or directory - otool -aSfh /mnt/buildbot/WebKit-BuildSlave/efl-linux-64-release-wk2/build/WebKitBuild/Release/bin/jsc (Errno::ENOENT)
	from Tools/Scripts/run-jsc-stress-tests:181:in `machOArchitectureCode'
	from Tools/Scripts/run-jsc-stress-tests:193:in `determineArchitecture'
	from Tools/Scripts/run-jsc-stress-tests:211:in `<main>'

It is a blocker bug, because the test coverage is zero because of this serious regression.
Comment 1 Csaba Osztrogonác 2014-05-21 01:10:38 PDT
+info: It seems this bug occurs only if ruby version is at 
least 1.9 , because backtick throws an excpetion from ruby 1.9.


$ cat foo.rb
`foo`
print "42\n"


Ubuntu 12.04
-------------
$ ruby --version
ruby 1.8.7 (2011-06-30 patchlevel 352) [x86_64-linux]

$ ruby foo.rb
foo.rb:1: command not found: foo
42

Ubuntu 12.10
-------------
$ ruby --version
ruby 1.9.3p194 (2012-04-20 revision 35410) [x86_64-linux]

$ ruby foo.rb
foo.rb:1:in ``': No such file or directory - foo (Errno::ENOENT)
        from foo.rb:1:in `<main>'
Comment 2 Éva Balázsfalvi 2014-05-21 01:39:11 PDT
Created attachment 231820 [details]
Patch
Comment 3 Csaba Osztrogonác 2014-05-21 05:00:21 PDT
Comment on attachment 231820 [details]
Patch

r=me
Comment 4 Csaba Osztrogonác 2014-05-21 05:02:17 PDT
Comment on attachment 231820 [details]
Patch

Clearing flags on attachment: 231820

Committed r169156: <http://trac.webkit.org/changeset/169156>
Comment 5 Csaba Osztrogonác 2014-05-21 05:02:24 PDT
All reviewed patches have been landed.  Closing bug.