Bug 133124

Summary: REGRESSION(r169105): fast/regions/cssom/region-range-for-box-crash.html is more crashy than before
Product: WebKit Reporter: Alexey Proskuryakov <ap>
Component: Layout and RenderingAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: ayao, commit-queue, esprehn+autocc, glenn, hyatt, jfernandez, kondapallykalyan, mihnea, rego
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch 2 none

Description Alexey Proskuryakov 2014-05-20 10:06:12 PDT
Looks like <http://trac.webkit.org/r169105> made this test less crashy on some bots, but more crashy on others:

http://webkit-test-results.appspot.com/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=fast%2Fregions%2Fcssom%2Fregion-range-for-box-crash.html

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   com.apple.WebCore             	0x00000001068b2f7e WebCore::SelectionIterator::checkForSpanner() + 46 (RenderView.cpp:69)
1   com.apple.WebCore             	0x00000001068b3767 WebCore::SelectionIterator::SelectionIterator(WebCore::RenderObject*) + 55 (RenderView.cpp:65)
2   com.apple.WebCore             	0x00000001068a51cd WebCore::SelectionIterator::SelectionIterator(WebCore::RenderObject*) + 29 (RenderView.cpp:65)
3   com.apple.WebCore             	0x00000001068a16e9 WebCore::RenderView::setSubtreeSelection(WebCore::SelectionSubtreeRoot&, WebCore::RenderObject*, int, WebCore::RenderObject*, int, WebCore::RenderView::SelectionRepaintMode) + 249 (RenderView.cpp:935)
4   com.apple.WebCore             	0x00000001068a3155 WebCore::RenderView::splitSelectionBetweenSubtrees(WebCore::RenderObject*, int, WebCore::RenderObject*, int, WebCore::RenderView::SelectionRepaintMode) + 1365 (RenderView.cpp:910)
5   com.apple.WebCore             	0x00000001068a15e1 WebCore::RenderView::setSelection(WebCore::RenderObject*, int, WebCore::RenderObject*, int, WebCore::RenderView::SelectionRepaintMode) + 449 (RenderView.cpp:865)
6   com.apple.WebCore             	0x00000001068a3234 WebCore::RenderView::clearSelection() + 84 (RenderView.cpp:1078)
7   com.apple.WebCore             	0x00000001066507b7 WebCore::RenderElement::removeChildInternal(WebCore::RenderObject&, WebCore::RenderElement::NotifyChildrenType) + 487 (RenderElement.cpp:621)
8   com.apple.WebCore             	0x00000001066505c2 WebCore::RenderElement::removeChild(WebCore::RenderObject&) + 34 (RenderElement.cpp:521)
Comment 1 Alexey Proskuryakov 2014-05-20 10:09:37 PDT
Skipped in <http://trac.webkit.org/r169117>.
Comment 2 Mihnea Ovidenie 2014-05-22 05:05:36 PDT
Created attachment 231876 [details]
Patch
Comment 3 Mihnea Ovidenie 2014-05-22 05:45:48 PDT
Created attachment 231878 [details]
Patch 2

Unskip the test file too.
Comment 4 Dave Hyatt 2014-05-23 11:31:13 PDT
Comment on attachment 231878 [details]
Patch 2

r=me
Comment 5 WebKit Commit Bot 2014-05-23 12:02:02 PDT
Comment on attachment 231878 [details]
Patch 2

Clearing flags on attachment: 231878

Committed r169273: <http://trac.webkit.org/changeset/169273>
Comment 6 WebKit Commit Bot 2014-05-23 12:02:08 PDT
All reviewed patches have been landed.  Closing bug.
Comment 7 David Kilzer (:ddkilzer) 2014-05-30 18:38:30 PDT
*** Bug 133252 has been marked as a duplicate of this bug. ***