Bug 132743

Summary: Rename WebKit2.framework to WebKit.framework
Product: WebKit Reporter: Anders Carlsson <andersca>
Component: New BugsAssignee: Anders Carlsson <andersca>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue, eric.carlson, glenn, jer.noble, philipj, sergio
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch mitz: review+

Description Anders Carlsson 2014-05-09 09:39:56 PDT
Rename WebKit2.framework to WebKit.framework
Comment 1 Anders Carlsson 2014-05-09 10:03:43 PDT
Created attachment 231160 [details]
Patch
Comment 2 WebKit Commit Bot 2014-05-09 10:06:47 PDT
Attachment 231160 [details] did not pass style-queue:


ERROR: Source/WebKit2/UIProcess/API/C/WebKit2_C.h:32:  Alphabetical sorting problem.  [build/include_order] [4]
ERROR: Source/WebKit2/UIProcess/API/C/WebKit2_C.h:33:  Alphabetical sorting problem.  [build/include_order] [4]
ERROR: Source/WebKit2/Shared/API/Cocoa/WebKit.m:31:  Extra space before ( in function call  [whitespace/parens] [4]
Total errors found: 3 in 243 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 mitz 2014-05-09 11:15:49 PDT
Comment on attachment 231160 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=231160&action=review

> Source/WebKit2/Configurations/WebKit2.xcconfig:27
> +INFOPLIST_FILE = mac/WebKit2.plist;

Let’s call this Info-WebKit2.plist

> Source/WebKit2/Shared/EntryPointUtilities/mac/XPCService/XPCServiceMain.mm:45
> +                CFBundleRef webKit2Bundle = CFBundleGetBundleWithIdentifier(CFSTR("com.apple.WebKit"));

Let’s rename this to webKitBundle.

> Source/WebKit2/UIProcess/Launcher/mac/ProcessLauncherMac.mm:92
> +    NSBundle *webKit2Bundle = [NSBundle bundleWithIdentifier:@"com.apple.WebKit"];

webKitBundle

> Source/WebKit2/WebKit2.xcodeproj/project.pbxproj:8005
> +				WebKit2.xcodeproj,

Strange

> Source/WebKit2/WebKit2.xcodeproj/project.pbxproj:9277
> +				VERSION_INFO_PREFIX = "";

Can we get rid of this?

> ChangeLog:13
> +        * WebKit.xcworkspace/xcshareddata/xcschemes/All Source (target WebProcess).xcscheme:
> +        Ditto.

There’s another shared scheme to update here.
Comment 4 Anders Carlsson 2014-05-09 11:40:47 PDT
Committed r168541: <http://trac.webkit.org/changeset/168541>