Bug 132551

Summary: REGRESSION (r168244): compositing/visibility/visibility-image-layers-dynamic.html failing.
Product: WebKit Reporter: Andreas Kling <kling>
Component: Layout and RenderingAssignee: Beth Dakin <bdakin>
Status: RESOLVED FIXED    
Severity: Normal CC: bdakin, kling
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch thorton: review+

Description Andreas Kling 2014-05-04 17:41:31 PDT
Regression from <https://trac.webkit.org/r168244>.

--- /Volumes/Data/slave/mountainlion-debug-tests-wk1/build/layout-test-results/compositing/visibility/visibility-image-layers-dynamic-expected.txt
+++ /Volumes/Data/slave/mountainlion-debug-tests-wk1/build/layout-test-results/compositing/visibility/visibility-image-layers-dynamic-actual.txt
@@ -4,6 +4,7 @@
 Initial
 
 (GraphicsLayer
+  (anchor 0.00 0.00)
   (bounds 785.00 626.00)
   (children 1
     (GraphicsLayer
@@ -54,10 +55,11 @@
 After step 1
 
 (GraphicsLayer
-  (bounds 785.00 1366.00)
+  (anchor 0.00 0.00)
+  (bounds 785.00 1381.00)
   (children 1
     (GraphicsLayer
-      (bounds 785.00 1366.00)
+      (bounds 785.00 1381.00)
       (contentsOpaque 1)
       (children 3
         (GraphicsLayer
@@ -103,10 +105,11 @@
 After step 2
 
 (GraphicsLayer
-  (bounds 785.00 2090.00)
+  (anchor 0.00 0.00)
+  (bounds 785.00 2120.00)
   (children 1
     (GraphicsLayer
-      (bounds 785.00 2090.00)
+      (bounds 785.00 2120.00)
       (contentsOpaque 1)
       (children 3
         (GraphicsLayer
Comment 1 Andreas Kling 2014-05-04 17:44:09 PDT
Marked as failing in <http://trac.webkit.org/changeset/168251>
Comment 2 Beth Dakin 2014-05-04 19:05:21 PDT
Thank you, Andreas! I will consult some folks tomorrow about what to make of how these bounds that seem to historically change a lot throughout the history of the test.
Comment 3 Beth Dakin 2014-05-05 12:37:15 PDT
Created attachment 230847 [details]
Patch

Oh this is hilarious. Thanks to Simon for figuring this out.  The bounds have increased in size  because the size of the layer tree dump effects the bounds! So now that we are printing out anchor points, the bound increase by 15 pixels for every new anchor point print-out.

Just a re-baseline after all.
Comment 4 Tim Horton 2014-05-05 12:38:36 PDT
Comment on attachment 230847 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=230847&action=review

> LayoutTests/ChangeLog:15
> +        * platform/mac/compositing/visibility/visibility-image-layers-dynamic-expected.txt:

Maybe leave a comment in the test?
Comment 5 Beth Dakin 2014-05-05 12:47:31 PDT
(In reply to comment #4)
> (From update of attachment 230847 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=230847&action=review
> 
> > LayoutTests/ChangeLog:15
> > +        * platform/mac/compositing/visibility/visibility-image-layers-dynamic-expected.txt:
> 
> Maybe leave a comment in the test?

I added one. Thanks, Tim!

http://trac.webkit.org/changeset/168310