Bug 132531

Summary: REGRESSION (r156546): Default media controls are laid out incorrectly when media element is styled with direction:rtl
Product: WebKit Reporter: mitz
Component: MediaAssignee: Maciej Stachowiak <mjs>
Status: RESOLVED FIXED    
Severity: Normal CC: calvaris, commit-queue, dino, eric.carlson, glenn, jer.noble, mjs, ossy, philipj, sergio, webkit-bug-importer
Priority: P1 Keywords: HasReduction, InRadar, Regression
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
URL: data:text/html,<video%20dir=rtl%20controls%20src="http://movies.apple.com/movies/us/apple/ipoditunes/2007/touch/ads/apple_ipodtouch_touch_r640-9cie.mov">
Attachments:
Description Flags
Patch mrowe: review+

Description mitz 2014-05-03 14:36:22 PDT
To reproduce: navigate to the URL. Hover over the video to make the controls show. All of the controls are laid out in reverse order and the playhead is moving from right to left.

This was caused by http://trac.webkit.org/r156546, the fix for bug 120895.
Comment 1 Radar WebKit Bug Importer 2014-05-03 14:38:36 PDT
<rdar://problem/16806267>
Comment 2 Maciej Stachowiak 2014-05-18 00:10:48 PDT
Created attachment 231651 [details]
Patch
Comment 3 Maciej Stachowiak 2014-05-18 15:04:17 PDT
Committed r169019: <http://trac.webkit.org/changeset/169019>
Comment 4 Csaba Osztrogon√°c 2014-05-19 08:23:54 PDT
Comment on attachment 231651 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=231651&action=review

> LayoutTests/platform/mac/TestExpectations:-1172
> -webkit.org/b/122021 media/video-rtl.html

This test is very flakey on the Apple Mac bots. Could you possibly 
check and fix it? Or skip it again to unbreak dead Apple Mac EWS.
Comment 5 Joseph Pecoraro 2015-11-12 20:57:26 PST
*** Bug 122022 has been marked as a duplicate of this bug. ***