Bug 131974

Summary: REGRESSION (r151839): Subframe keeps getting mousemove events with the same coordinates after hiding a hovered element.
Product: WebKit Reporter: Andreas Kling <kling>
Component: UI EventsAssignee: Andreas Kling <kling>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue, esprehn+autocc, kangil.han, kling
Priority: P2 Keywords: InRadar
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch
none
Patch none

Description Andreas Kling 2014-04-22 00:57:56 PDT
<rdar://problem/15907469>
Comment 1 Andreas Kling 2014-04-22 01:01:04 PDT
Created attachment 229868 [details]
Patch
Comment 2 Andreas Kling 2014-04-22 01:05:24 PDT
The layout test timeouts are 260ms because the fake mousemove events are sent on 250ms timers. (Urgh.)
Comment 3 Andreas Kling 2014-04-22 01:22:23 PDT
Created attachment 229870 [details]
Patch

Add a hunk to the ChangeLog about the solution as well..
Comment 4 Andreas Kling 2014-04-22 02:14:03 PDT
Comment on attachment 229870 [details]
Patch

Test has some race condition on WK2. Will fixup tomorrow.
Comment 5 Andreas Kling 2014-04-22 12:33:49 PDT
Created attachment 229906 [details]
Patch

Okay, here we go again!
Comment 6 Benjamin Poulain 2014-04-22 13:31:26 PDT
Comment on attachment 229906 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=229906&action=review

Make sense.

> LayoutTests/fast/events/ghostly-mousemoves-in-subframe.html:75
> +                    }, 500);

Can you use a busy wait here instead of a 0.5s wait?
Comment 7 Andreas Kling 2014-04-22 14:54:47 PDT
(In reply to comment #6)
> (From update of attachment 229906 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=229906&action=review
> 
> Make sense.
> 
> > LayoutTests/fast/events/ghostly-mousemoves-in-subframe.html:75
> > +                    }, 500);
> 
> Can you use a busy wait here instead of a 0.5s wait?

That'd be a bit weird, since I'm waiting for something *not* to happen.

I'm gonna land this as-is, if it turns out troublesome, and you're reading this comment in the future wondering what I was thinking, sorry :|
Comment 8 Andreas Kling 2014-04-22 14:56:24 PDT
Comment on attachment 229906 [details]
Patch

Clearing flags on attachment: 229906

Committed r167684: <http://trac.webkit.org/changeset/167684>
Comment 9 Andreas Kling 2014-04-22 14:56:27 PDT
All reviewed patches have been landed.  Closing bug.