Bug 131731

Summary: [GTK] Unit test /webkit2/WebKitWebView/page-visibility from WebKit2Gtk/TestWebKitWebView fails
Product: WebKit Reporter: Carlos Alberto Lopez Perez <clopez>
Component: Tools / TestsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: cgarcia
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Other   
OS: Linux   
Attachments:
Description Flags
Patch zan: review+

Description Carlos Alberto Lopez Perez 2014-04-16 07:08:00 PDT
The test /webkit2/WebKitWebView/page-visibility from WebKit2Gtk/TestWebKitWebView fails or gives timeout.

The failure is the following:

TEST: ./Tools/gtk/../../WebKitBuild/Release/bin/TestWebKitAPI/WebKit2Gtk/TestWebKitWebView... (pid=15909)
  /webkit2/WebKitWebView/default-context:                              OK
  /webkit2/WebKitWebView/custom-charset:                               OK
  /webkit2/WebKitWebView/settings:                                     OK
  /webkit2/WebKitWebView/zoom-level:                                   OK
  /webkit2/WebKitWebView/run-javascript:                               OK
  /webkit2/WebKitWebView/fullscreen:                                   OK
  /webkit2/WebKitWebView/can-show-mime-type:                           OK
  /webkit2/WebKitWebView/submit-form:                                  OK
  /webkit2/WebKitWebView/save:                                         OK
  /webkit2/WebKitWebView/page-visibility:                              **
ERROR:../../Tools/TestWebKitAPI/Tests/WebKit2Gtk/TestWebKitWebView.cpp:444:void testWebViewPageVisibility(WebViewTest*, gconstpointer): assertion failed (valueString.get() == "hidden"): ("prerender" == "hidden")
FAIL
GTester: last random seed: R02S4017bfafdb3489cd3c0fbd8a0ac57391
(pid=15973)
FAIL: ./Tools/gtk/../../WebKitBuild/Release/bin/TestWebKitAPI/WebKit2Gtk/TestWebKitWebView


Probably this failure was caused by r163821 <http://trac.webkit.org/r163821>

I will be marking the test to be skipped on Tools/Scripts/run-gtk-tests
Comment 1 Carlos Alberto Lopez Perez 2014-04-17 05:42:37 PDT
(In reply to comment #0)
> I will be marking the test to be skipped on Tools/Scripts/run-gtk-tests

Skipped the test on r167359 <http://trac.webkit.org/r167359>.
Comment 2 Carlos Garcia Campos 2015-01-28 05:06:30 PST
Created attachment 245532 [details]
Patch
Comment 3 Carlos Garcia Campos 2015-01-28 05:45:02 PST
Committed r179248: <http://trac.webkit.org/changeset/179248>