Bug 131591

Summary: [GTK] YouCompleteMe doesn't work for cmake build system.
Product: WebKit Reporter: ChangSeok Oh <changseok>
Component: WebKitGTKAssignee: ChangSeok Oh <changseok>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue, dbates, gns, mrobinson
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch
none
Patch none

Description ChangSeok Oh 2014-04-13 08:54:27 PDT
SSIA. I'm fixing this. A patch is coming soon.
Comment 1 ChangSeok Oh 2014-04-13 12:17:56 PDT
Created attachment 229238 [details]
Patch
Comment 2 Martin Robinson 2014-04-14 07:46:19 PDT
Comment on attachment 229238 [details]
Patch

The Autotools build system has been removed. You probably need to update your patch to reflect that.
Comment 3 ChangSeok Oh 2014-04-14 11:01:29 PDT
Created attachment 229292 [details]
Patch
Comment 4 ChangSeok Oh 2014-04-14 11:07:01 PDT
*** Bug 131490 has been marked as a duplicate of this bug. ***
Comment 5 Martin Robinson 2014-04-14 11:14:39 PDT
Comment on attachment 229292 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=229292&action=review

> Tools/gtk/ycm_extra_conf.py:102
> +        print "Could not find compile_commands.json in %s, You might forget to add CMAKE_EXPORT_COMPILE_COMMANDS=ON to cmakeargs" % build_path
>          return result

Would it make sense to add this to build-webkit? Does it significantly slow cmake down?
Comment 6 ChangSeok Oh 2014-04-14 21:30:13 PDT
(In reply to comment #5)
> (From update of attachment 229292 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=229292&action=review
> 
> > Tools/gtk/ycm_extra_conf.py:102
> > +        print "Could not find compile_commands.json in %s, You might forget to add CMAKE_EXPORT_COMPILE_COMMANDS=ON to cmakeargs" % build_path
> >          return result
> 
> Would it make sense to add this to build-webkit? Does it significantly slow cmake down?

No. I don't think it affects performance down. Actually I considered to add it in build-webkit, but I didn't becuase of non-vim user.(It's useless for them.) If no objection, let me add it. Thanks :)
Comment 7 ChangSeok Oh 2014-04-15 08:45:40 PDT
Created attachment 229371 [details]
Patch
Comment 8 ChangSeok Oh 2014-04-17 21:35:37 PDT
Comment on attachment 229371 [details]
Patch

Thanks.
Comment 9 WebKit Commit Bot 2014-04-17 22:06:12 PDT
Comment on attachment 229371 [details]
Patch

Clearing flags on attachment: 229371

Committed r167482: <http://trac.webkit.org/changeset/167482>
Comment 10 WebKit Commit Bot 2014-04-17 22:06:18 PDT
All reviewed patches have been landed.  Closing bug.