Bug 131496

Summary: [ATK] Layout Test accessibility/help-text.html is failing
Product: WebKit Reporter: Carlos Alberto Lopez Perez <clopez>
Component: Tools / TestsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: apinheiro, jdiggs, k.czech, k.wolanski, mario, mpakulavelrutka
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Other   
OS: Linux   

Description Carlos Alberto Lopez Perez 2014-04-10 10:03:50 PDT
The following layout test is failing on GTK

accessibility/help-text.html


This test was introduced on r167054 (see bug #130386 )


The diff is the following:

--- /stuff/webkit/webkit/layout-test-results/accessibility/help-text-expected.txt
+++ /stuff/webkit/webkit/layout-test-results/accessibility/help-text-actual.txt
@@ -1,28 +1,20 @@
+CONSOLE MESSAGE: line 68: TypeError: null is not an object (evaluating 'ax.helpText.replace')
+foo foo foo
+foo
+
+foo  foo  foo  
+caption
+
+text
+foo
+foo
+foo
 Tests accessibility help text in a variety of examples.
 
 On success, you will see a series of "PASS" messages, followed by "TEST COMPLETE".
 
 
-PASS: Help text for <a> is ""
-PASS: Help text for <a> is "bar"
-PASS: Help text for <a> is "baz"
-PASS: Help text for <a> is ""
-PASS: Help text for <h1> is "bar"
-PASS: Help text for <a> is ""
-PASS: Help text for <button> is ""
-PASS: Help text for <button> is "bar"
-PASS: Help text for <button> is "baz"
-PASS: Help text for <button> is ""
-PASS: Help text for <table> is "table summary"
-PASS: Help text for <input> is ""
-PASS: Help text for <div> is ""
-PASS: Help text for <main> is "bar"
-PASS: Help text for <button> is ""
-PASS: Help text for <main> is ""
-PASS: Help text for <div> is ""
-PASS: Help text for <a> is "bar"
-PASS: Help text for <div> is ""
-PASS successfullyParsed is true
+FAIL successfullyParsed should be true (of type boolean). Was undefined (of type undefined).
 
 TEST COMPLETE
Comment 1 Krzysztof Wolanski 2014-04-22 07:12:51 PDT
This test returns the same output in EFL port.
Comment 2 Joanmarie Diggs (irc: joanie) 2016-05-17 15:49:57 PDT

*** This bug has been marked as a duplicate of bug 157187 ***