Bug 130931

Summary: LiveNodeLists should use ElementDescendantIterator
Product: WebKit Reporter: Antti Koivisto <koivisto>
Component: DOMAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue, esprehn+autocc, gyuyoung.kim, kangil.han, kling, rniwa
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
patch kling: review+

Description Antti Koivisto 2014-03-29 12:44:18 PDT
It is better.
Comment 1 Antti Koivisto 2014-03-29 13:00:23 PDT
Created attachment 228114 [details]
patch
Comment 2 WebKit Commit Bot 2014-03-29 13:02:10 PDT
Attachment 228114 [details] did not pass style-queue:


ERROR: Source/WebCore/dom/ElementDescendantIterator.h:338:  value_type is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
ERROR: Source/WebCore/dom/ElementDescendantIterator.h:341:  value_type is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
Total errors found: 2 in 8 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Andreas Kling 2014-03-29 14:34:47 PDT
Comment on attachment 228114 [details]
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=228114&action=review

r=me, very glorious patch A+!

> Source/WebCore/dom/CollectionIndexCache.h:38
> +    CollectionIndexCache(const Collection&);

explicit
Comment 4 Antti Koivisto 2014-03-30 01:37:43 PDT
https://trac.webkit.org/r166460