Bug 130463

Summary: REGRESSION (OS X 10.9.2): PageVisibilityStateWithWindowChanges.WebKit2 API test fails
Product: WebKit Reporter: Alexey Proskuryakov <ap>
Component: WebKit2Assignee: Alexey Proskuryakov <ap>
Status: RESOLVED FIXED    
Severity: Normal CC: barraclough, cdumez, commit-queue, joepeck, simon.fraser, thorton
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
proposed fix none

Description Alexey Proskuryakov 2014-03-19 10:21:35 PDT
Since regression testing bots were upgraded to OS X 10.9.2 yesterday, PageVisibilityStateWithWindowChanges.WebKit2 started to time out:

http://build.webkit.org/builders/Apple%20Mavericks%20Debug%20WK1%20(Tests)/builds/3917/steps/run-api-tests/logs/stdio
Comment 1 Alexey Proskuryakov 2014-03-19 10:27:59 PDT
Disabled the test in <http://trac.webkit.org/r165899>.
Comment 2 Alexey Proskuryakov 2015-04-07 20:43:21 PDT
See also: rdar://problem/20461342
Comment 3 Alexey Proskuryakov 2015-05-22 12:08:57 PDT
Created attachment 253598 [details]
proposed fix
Comment 4 WebKit Commit Bot 2015-05-22 17:27:06 PDT
Comment on attachment 253598 [details]
proposed fix

Clearing flags on attachment: 253598

Committed r184807: <http://trac.webkit.org/changeset/184807>
Comment 5 WebKit Commit Bot 2015-05-22 17:27:11 PDT
All reviewed patches have been landed.  Closing bug.