Bug 130319

Summary: [EFL][WK2] Rename async APIs for better consistency with EFL
Product: WebKit Reporter: Ryuan Choi <ryuan.choi>
Component: WebKit EFLAssignee: Ryuan Choi <ryuan.choi>
Status: RESOLVED FIXED    
Severity: Normal CC: bunhere, cdumez, commit-queue, gyuyoung.kim, gyuyoung.kim, lucas.de.marchi, sergio
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch none

Ryuan Choi
Reported 2014-03-16 23:51:45 PDT
We'd better to remove Async keyword from the APIs for the consistency.
Attachments
Patch (24.24 KB, patch)
2014-03-17 20:42 PDT, Ryuan Choi
no flags
Patch (27.70 KB, patch)
2014-03-18 17:43 PDT, Ryuan Choi
no flags
Ryuan Choi
Comment 1 2014-03-17 18:04:15 PDT
Like https://lists.webkit.org/pipermail/webkit-efl/2014-March/000583.html, We'd better to follow EFL style more for the async APIs.
Ryuan Choi
Comment 2 2014-03-17 20:42:51 PDT
Gyuyoung Kim
Comment 3 2014-03-17 21:28:36 PDT
Comment on attachment 227006 [details] Patch r=me based on efl mailing list discussion.
Jinwoo Song
Comment 4 2014-03-17 21:39:40 PDT
Comment on attachment 227006 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=227006&action=review > Source/WebKit2/UIProcess/API/efl/ewk_application_cache_manager.cpp:45 > +struct Get_Origins_Async_Data { *Ewk_Application_Cache_Origins_Async_Data* seems to be more clear. > Source/WebKit2/UIProcess/API/efl/ewk_cookie_manager.cpp:195 > struct Get_Hostnames_Async_Data { *Ewk_Cookie_Manager_Hostnames_Async_Data*? > Source/WebKit2/UIProcess/API/efl/ewk_database_manager.cpp:66 > struct Ewk_Database_Origins_Async_Get_Context { *Ewk_Database_Origins_Async_Data*? > Source/WebKit2/UIProcess/API/efl/ewk_storage_manager.cpp:66 > struct Ewk_Storage_Origins_Async_Get_Context { *Ewk_Storage_Origins_Async_Data*?
Ryuan Choi
Comment 5 2014-03-18 07:41:29 PDT
(In reply to comment #4) > (From update of attachment 227006 [details]) > View in context: https://bugs.webkit.org/attachment.cgi?id=227006&action=review > > > Source/WebKit2/UIProcess/API/efl/ewk_application_cache_manager.cpp:45 > > +struct Get_Origins_Async_Data { > > *Ewk_Application_Cache_Origins_Async_Data* seems to be more clear. > > > Source/WebKit2/UIProcess/API/efl/ewk_cookie_manager.cpp:195 > > struct Get_Hostnames_Async_Data { > > *Ewk_Cookie_Manager_Hostnames_Async_Data*? > > > Source/WebKit2/UIProcess/API/efl/ewk_database_manager.cpp:66 > > struct Ewk_Database_Origins_Async_Get_Context { > > *Ewk_Database_Origins_Async_Data*? > > > Source/WebKit2/UIProcess/API/efl/ewk_storage_manager.cpp:66 > > struct Ewk_Storage_Origins_Async_Get_Context { > > *Ewk_Storage_Origins_Async_Data*? Like discussed in IRC, I agree that it looks ugly but I am not sure whether I can rename them in this bug. gyuyoung, what do you think about it? If I can rename them in this bug, I will rebase the patch.
Gyuyoung Kim
Comment 6 2014-03-18 07:46:53 PDT
Comment on attachment 227006 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=227006&action=review >>> Source/WebKit2/UIProcess/API/efl/ewk_application_cache_manager.cpp:45 >>> +struct Get_Origins_Async_Data { >> >> *Ewk_Application_Cache_Origins_Async_Data* seems to be more clear. > > Like discussed in IRC, I agree that it looks ugly but I am not sure whether I can rename them in this bug. > > gyuyoung, what do you think about it? > > If I can rename them in this bug, I will rebase the patch. I don't mind to rename these in this patch together.
Ryuan Choi
Comment 7 2014-03-18 17:43:58 PDT
Jinwoo Song
Comment 8 2014-03-18 17:50:00 PDT
Comment on attachment 227137 [details] Patch Thanks for renaming the structures. Much better!
WebKit Commit Bot
Comment 9 2014-03-18 18:58:03 PDT
Comment on attachment 227137 [details] Patch Clearing flags on attachment: 227137 Committed r165864: <http://trac.webkit.org/changeset/165864>
WebKit Commit Bot
Comment 10 2014-03-18 19:03:34 PDT
All reviewed patches have been landed. Closing bug.
Note You need to log in before you can comment on or make changes to this bug.