|Summary:||WebCrypto HmacKeyParams.length is now bits, not bytes|
|Product:||WebKit||Reporter:||Alexey Proskuryakov <ap>|
|Component:||WebCore Misc.||Assignee:||Nobody <webkit-unassigned>|
|Severity:||Normal||CC:||bfulgham, buildbot, commit-queue, esprehn+autocc, iseki.m.aa, jiewen_tan, kangil.han, rniwa, webkit-bug-importer|
|Version:||528+ (Nightly build)|
|Bug Depends on:|
Description Alexey Proskuryakov 2014-03-05 11:38:38 PST
The spec has changed, WebCrypto HmacKeyParams.length is now in bits, not bytes. This makes it consistent with other lengths.
Comment 2 WebKit Commit Bot 2014-11-03 01:51:45 PST
Attachment 240835 [details] did not pass style-queue: ERROR: LayoutTests/ChangeLog:6: Line contains tab character. [whitespace/tab]  ERROR: Source/WebCore/dom/ExceptionCode.h:64: enum members should use InterCaps with an initial capital letter. [readability/enum_casing]  ERROR: Source/WebCore/ChangeLog:8: You should remove the 'No new tests' and either add and list tests, or explain why no new tests were possible. [changelog/nonewtests]  Total errors found: 3 in 12 files If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 iseki 2014-11-03 02:00:53 PST
Created attachment 240836 [details] TestResults.pdf This file is the result of the commonad "./Tools/Scripts/run-webkit-tests -q /$USER_PATH/WebKit/LayoutTests/crypto/subtle/l"
Comment 4 iseki 2014-11-03 02:36:16 PST
Sorry, please ignore the patch at Comment2. I should not add new error code into DOMCoreExceprion. @Alexey Proskuryakov I'm new to WebKit. Would you mind helping me to fix this bug? I think I should make new ExceptionFile like IDBDatabaseException to handle DATA_ERR. https://trac.webkit.org/browser/trunk/Source/WebCore/Modules/indexeddb/IDBDatabaseException.h
Comment 5 Alexey Proskuryakov 2014-11-03 09:13:01 PST
Comment on attachment 240835 [details] Patch We already shipped it like this, so we can't just fix it without aligning with the rest of the spec, and removing webkit prefix. Otherwise, there is no good way for JS code to know what units the length is in.
Comment 6 iseki 2014-11-03 14:50:08 PST
Thank you for your answering. Is there plan to remove WebKit prefix?
Comment 7 Alexey Proskuryakov 2014-11-03 15:02:07 PST
I don't think that anyone is working on this now. It may be best to start a parallel implementation under an #if, and enable it when done. There were so many changes in the spec since last year that it should be easier to implement it from scratch than to fix the old implementation.