Bug 129685

Summary: [GStreamer] WebSource doesn't need the "iradio-mode" property
Product: WebKit Reporter: Andres Gomez Garcia <agomez>
Component: WebKitGTKAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: andersca, calvaris, cgarcia, commit-queue, gustavo, menard, mrobinson, pnormand, vjaquez
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch none

Description Andres Gomez Garcia 2014-03-04 08:53:13 PST
As we have been discussing at https://bugzilla.gnome.org/show_bug.cgi?id=725383 , the "iradio-mode" property was intended to be automatically set by "uridecodebin".

For quite some time, this was not happening and now we are removing this automatic mechanism since it doesn't bring any advantage.

The "iradio-mode" property is a private property that was not even exposed so it could only be set by the playbin through the uridecodebin.

Let's sent always the "icy-metadata" header and remove the code from this property.
Comment 1 Andres Gomez Garcia 2014-03-05 05:43:58 PST
Created attachment 225876 [details]
Patch
Comment 2 WebKit Commit Bot 2014-03-05 06:43:22 PST
Comment on attachment 225876 [details]
Patch

Clearing flags on attachment: 225876

Committed r165106: <http://trac.webkit.org/changeset/165106>
Comment 3 WebKit Commit Bot 2014-03-05 06:43:26 PST
All reviewed patches have been landed.  Closing bug.