Bug 12926

Summary: transform attribute not respected in nested <use> elements
Product: WebKit Reporter: Nikolas Zimmermann <zimmermann>
Component: SVGAssignee: Nikolas Zimmermann <zimmermann>
Status: RESOLVED DUPLICATE    
Severity: Normal    
Priority: P2    
Version: 523.x (Safari 3)   
Hardware: Mac   
OS: OS X 10.4   
Attachments:
Description Flags
Initial patch none

Description Nikolas Zimmermann 2007-02-28 07:08:45 PST
Shadow tree expansion currently overrides existing transform attributes instead of concating - as asked by the spec. Attaching simple patch to fix it.
Comment 1 Nikolas Zimmermann 2007-02-28 07:09:58 PST
Created attachment 13421 [details]
Initial patch

This does NOT contain any layout tests results (-expected.txt/png) as someone needs to generate these results with a build which doesn't contain the svg experimental features. (use is disabled in ToT)
Comment 2 Nikolas Zimmermann 2007-03-01 10:05:17 PST

*** This bug has been marked as a duplicate of 12936 ***