Bug 129167

Summary: After copy and paste, cursor may appear to be above the bottom of content
Product: WebKit Reporter: Myles C. Maxfield <mmaxfield>
Component: New BugsAssignee: Myles C. Maxfield <mmaxfield>
Status: RESOLVED FIXED    
Severity: Normal CC: dino, jonlee, rniwa, simon.fraser, thorton, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch rniwa: review+

Description Myles C. Maxfield 2014-02-21 13:49:46 PST
After copy and paste, cursor may appear to be above the bottom of content
Comment 1 Myles C. Maxfield 2014-02-21 13:52:49 PST
Created attachment 224900 [details]
Patch
Comment 2 Myles C. Maxfield 2014-02-21 13:53:17 PST
*** Bug 129165 has been marked as a duplicate of this bug. ***
Comment 3 Myles C. Maxfield 2014-02-21 13:53:32 PST
*** Bug 129132 has been marked as a duplicate of this bug. ***
Comment 4 Myles C. Maxfield 2014-02-21 13:54:58 PST
<rdar://problem/16126067>
Comment 5 Ryosuke Niwa 2014-02-21 15:30:43 PST
Comment on attachment 224900 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=224900&action=review

> Source/WebCore/editing/markup.cpp:632
>      if (accumulator.needRelativeStyleWrapper() && needsPositionStyleConversion) {
> +        accumulator.appendString("<div style=\"clear: both;\"></div>");

Can we add a flag in StylizedAccumulator to look for floats and only generate this when we saw a float?
Comment 6 Myles C. Maxfield 2014-02-21 19:09:17 PST
http://trac.webkit.org/changeset/164521