Summary: | Make it possible to reply asynchronously to JavaScript panels and alerts | ||||||
---|---|---|---|---|---|---|---|
Product: | WebKit | Reporter: | Anders Carlsson <andersca> | ||||
Component: | New Bugs | Assignee: | Anders Carlsson <andersca> | ||||
Status: | RESOLVED FIXED | ||||||
Severity: | Normal | CC: | commit-queue | ||||
Priority: | P2 | ||||||
Version: | 528+ (Nightly build) | ||||||
Hardware: | Unspecified | ||||||
OS: | Unspecified | ||||||
Attachments: |
|
Description
Anders Carlsson
2014-02-20 13:17:26 PST
Created attachment 224791 [details]
Patch
Attachment 224791 [details] did not pass style-queue:
ERROR: Source/WebKit2/Scripts/webkit2/LegacyMessageReceiver-expected.cpp:77: _result is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4]
ERROR: Source/WebKit2/Scripts/webkit2/LegacyMessageReceiver-expected.cpp:96: _result is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4]
ERROR: Source/WebKit2/Scripts/webkit2/MessageReceiver-expected.cpp:77: _result is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4]
ERROR: Source/WebKit2/Scripts/webkit2/MessageReceiver-expected.cpp:96: _result is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4]
ERROR: Source/WebKit2/UIProcess/WebPageProxy.cpp:2645: The parameter type should use PassRefPtr instead of RefPtr. [readability/pass_ptr] [5]
ERROR: Source/WebKit2/UIProcess/WebPageProxy.cpp:2653: More than one command on the same line [whitespace/newline] [4]
ERROR: Source/WebKit2/UIProcess/WebPageProxy.cpp:2653: Missing space before { [whitespace/braces] [5]
ERROR: Source/WebKit2/UIProcess/WebPageProxy.cpp:2656: The parameter type should use PassRefPtr instead of RefPtr. [readability/pass_ptr] [5]
ERROR: Source/WebKit2/UIProcess/WebPageProxy.cpp:2664: More than one command on the same line [whitespace/newline] [4]
ERROR: Source/WebKit2/UIProcess/WebPageProxy.cpp:2667: The parameter type should use PassRefPtr instead of RefPtr. [readability/pass_ptr] [5]
ERROR: Source/WebKit2/UIProcess/WebPageProxy.cpp:2675: More than one command on the same line [whitespace/newline] [4]
ERROR: Source/WebKit2/UIProcess/WebPageProxy.h:959: The parameter type should use PassRefPtr instead of RefPtr. [readability/pass_ptr] [5]
ERROR: Source/WebKit2/UIProcess/WebPageProxy.h:960: The parameter type should use PassRefPtr instead of RefPtr. [readability/pass_ptr] [5]
ERROR: Source/WebKit2/UIProcess/WebPageProxy.h:961: The parameter type should use PassRefPtr instead of RefPtr. [readability/pass_ptr] [5]
ERROR: Source/WebKit2/UIProcess/API/APIUIClient.h:72: Extra space before ( in function call [whitespace/parens] [4]
ERROR: Source/WebKit2/UIProcess/API/APIUIClient.h:73: Extra space before ( in function call [whitespace/parens] [4]
ERROR: Source/WebKit2/UIProcess/API/APIUIClient.h:74: Extra space before ( in function call [whitespace/parens] [4]
ERROR: Source/WebKit2/UIProcess/API/C/WKPage.cpp:1151: Extra space before ( in function call [whitespace/parens] [4]
ERROR: Source/WebKit2/UIProcess/API/C/WKPage.cpp:1161: Extra space before ( in function call [whitespace/parens] [4]
ERROR: Source/WebKit2/UIProcess/API/C/WKPage.cpp:1172: Extra space before ( in function call [whitespace/parens] [4]
Total errors found: 20 in 9 files
If any of these errors are false positives, please file a bug against check-webkit-style.
Comment on attachment 224791 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=224791&action=review > Source/WebKit2/UIProcess/WebPageProxy.h:959 > + void runJavaScriptAlert(uint64_t frameID, const String&, RefPtr<Messages::WebPageProxy::RunJavaScriptAlert::DelayedReply>); Extra space. Committed r164450: <http://trac.webkit.org/changeset/164450> This patch broke two API tests on Mac, which now assert. E-mailed Anders with details. |