Bug 129054

Summary: FTL should be able to convey branch weights to LLVM
Product: WebKit Reporter: Filip Pizlo <fpizlo>
Component: JavaScriptCoreAssignee: Filip Pizlo <fpizlo>
Status: RESOLVED FIXED    
Severity: Normal CC: atrick, barraclough, commit-queue, ggaren, mark.lam, mhahnenberg, mmirman, msaboff, nrotem, oliver, sam
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Bug Depends on:    
Bug Blocks: 112840, 129055    
Attachments:
Description Flags
the patch
none
the patch msaboff: review+

Description Filip Pizlo 2014-02-19 12:21:09 PST
Patch forthcoming.
Comment 1 Filip Pizlo 2014-02-19 13:05:43 PST
Created attachment 224665 [details]
the patch
Comment 2 WebKit Commit Bot 2014-02-19 13:07:28 PST
Attachment 224665 [details] did not pass style-queue:


ERROR: Source/JavaScriptCore/ftl/FTLLowerDFGToLLVM.cpp:1368:  Wrong number of spaces before statement. (expected: 24)  [whitespace/indent] [4]
ERROR: Source/JavaScriptCore/ftl/FTLOutput.h:76:  The parameter name "module" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/ftl/FTLOutput.h:85:  The parameter name "block" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/ftl/FTLOutput.h:87:  The parameter name "block" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/ftl/FTLOutput.h:188:  The parameter name "value" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/ftl/FTLOutput.h:212:  The parameter name "value" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/ftl/FTLOutput.h:250:  The parameter name "scale" adds no information, so it should be removed.  [readability/parameter_name] [5]
Total errors found: 7 in 11 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Filip Pizlo 2014-02-19 13:09:17 PST
(In reply to comment #2)
> Attachment 224665 [details] did not pass style-queue:
> 
> 
> ERROR: Source/JavaScriptCore/ftl/FTLLowerDFGToLLVM.cpp:1368:  Wrong number of spaces before statement. (expected: 24)  [whitespace/indent] [4]

You expected wrong.

> ERROR: Source/JavaScriptCore/ftl/FTLOutput.h:76:  The parameter name "module" adds no information, so it should be removed.  [readability/parameter_name] [5]
> ERROR: Source/JavaScriptCore/ftl/FTLOutput.h:85:  The parameter name "block" adds no information, so it should be removed.  [readability/parameter_name] [5]
> ERROR: Source/JavaScriptCore/ftl/FTLOutput.h:87:  The parameter name "block" adds no information, so it should be removed.  [readability/parameter_name] [5]
> ERROR: Source/JavaScriptCore/ftl/FTLOutput.h:188:  The parameter name "value" adds no information, so it should be removed.  [readability/parameter_name] [5]
> ERROR: Source/JavaScriptCore/ftl/FTLOutput.h:212:  The parameter name "value" adds no information, so it should be removed.  [readability/parameter_name] [5]
> ERROR: Source/JavaScriptCore/ftl/FTLOutput.h:250:  The parameter name "scale" adds no information, so it should be removed.  [readability/parameter_name] [5]

Fixed.

> Total errors found: 7 in 11 files
> 
> 
> If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 4 Filip Pizlo 2014-02-19 13:23:13 PST
Created attachment 224667 [details]
the patch

Made the termnology better (usually/rarely instead of always/never).
Comment 5 Michael Saboff 2014-02-19 13:24:06 PST
Comment on attachment 224667 [details]
the patch

r=me
Comment 6 WebKit Commit Bot 2014-02-19 13:25:28 PST
Attachment 224667 [details] did not pass style-queue:


ERROR: Source/JavaScriptCore/ftl/FTLLowerDFGToLLVM.cpp:1368:  Wrong number of spaces before statement. (expected: 24)  [whitespace/indent] [4]
Total errors found: 1 in 11 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 7 Filip Pizlo 2014-02-19 14:25:25 PST
Landed in http://trac.webkit.org/changeset/164389
Comment 8 Geoffrey Garen 2014-02-19 14:45:33 PST
Comment on attachment 224667 [details]
the patch

View in context: https://bugs.webkit.org/attachment.cgi?id=224667&action=review

> Source/JavaScriptCore/ftl/FTLWeight.h:55
> +        // LLVM accepts branch 32-bit unsigned branch weights but in dumps it might

"branch 32-bit unsigned branch"