Bug 12747

Summary: Kotoeri input does not work in input forms
Product: WebKit Reporter: Vince Vu <vincentqvu>
Component: New BugsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal    
Priority: P2    
Version: 420+   
Hardware: Mac   
OS: OS X 10.4   

Description Vince Vu 2007-02-12 12:50:20 PST
When I change my input method from to Kotoeri: Hiragana and attempt to type text into an input form, it does not work.  The inputed character will repeat.  For example, I will now switch to Hiragana input and push the 'a' key on the keyboard once:

&#12354;&#12354;&#12354;&#12354;&#12354;&#12354;&#12354;&#12354;&#12354;

The number of repeats seems consistent (here I  push 'e'):

&#12360;&#12360;&#12360;&#12360;&#12360;&#12360;&#12360;&#12360;&#12360;

(here I push 'k'):

&#12387;&#12387;&#12387;&#12387;&#12387;&#12387;&#12387;&#12387;k

With Webkit 418.9.1, input works correctly.  Pushing 'a' once will result in one &#12354;.
Comment 1 David Kilzer (:ddkilzer) 2007-02-12 13:30:03 PST

*** This bug has been marked as a duplicate of 12531 ***