Bug 126995

Summary: Web Inspector: For Remote Inspection link WebProcess's to their parent UIProcess
Product: WebKit Reporter: Joseph Pecoraro <joepeck>
Component: Web InspectorAssignee: Joseph Pecoraro <joepeck>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue, graouts, joepeck, timothy, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Attachments:
Description Flags
[PATCH] Proposed Fix none

Joseph Pecoraro
Reported 2014-01-14 10:40:05 PST
For remote inspection make WebProcesses a proxy application for the parent UIProcess. This way, if you have multiple WebProcesses hosting multiple WebPage's then all the WebPages can be listed under the UIProcess.
Attachments
[PATCH] Proposed Fix (9.96 KB, patch)
2014-01-14 11:32 PST, Joseph Pecoraro
no flags
Radar WebKit Bug Importer
Comment 1 2014-01-14 10:41:22 PST
Joseph Pecoraro
Comment 2 2014-01-14 11:32:01 PST
Created attachment 221183 [details] [PATCH] Proposed Fix
Timothy Hatcher
Comment 3 2014-01-14 11:53:09 PST
Comment on attachment 221183 [details] [PATCH] Proposed Fix View in context: https://bugs.webkit.org/attachment.cgi?id=221183&action=review > Source/JavaScriptCore/inspector/remote/RemoteInspector.mm:301 > + NSString *parentApplicationIdentifier = [NSString stringWithFormat:@"PID:%lu", (unsigned long)debuggableInfo.parentProcessIdentifier]; Is "PID:" needed? DO you need to strip that out later for the numeric value or do you just compare strings?
Joseph Pecoraro
Comment 4 2014-01-14 11:55:34 PST
(In reply to comment #3) > (From update of attachment 221183 [details]) > View in context: https://bugs.webkit.org/attachment.cgi?id=221183&action=review > > > Source/JavaScriptCore/inspector/remote/RemoteInspector.mm:301 > > + NSString *parentApplicationIdentifier = [NSString stringWithFormat:@"PID:%lu", (unsigned long)debuggableInfo.parentProcessIdentifier]; > > Is "PID:" needed? DO you need to strip that out later for the numeric value or do you just compare strings? Nope, PID is not needed. I just wanted this to be obvious that it was a String, and if we change it to be some other number in the future then we can give another prefix for what exactly that means. E.g. "BundleID:#", "PID:#", "XPC:#", etc. Just trying to be forward thinking.
WebKit Commit Bot
Comment 5 2014-01-14 12:19:33 PST
Comment on attachment 221183 [details] [PATCH] Proposed Fix Clearing flags on attachment: 221183 Committed r161994: <http://trac.webkit.org/changeset/161994>
WebKit Commit Bot
Comment 6 2014-01-14 12:19:35 PST
All reviewed patches have been landed. Closing bug.
Note You need to log in before you can comment on or make changes to this bug.