Bug 126889

Summary: Subpixel Layout: <input type=password id=password> reports wrong offsetWidth value.
Product: WebKit Reporter: zalan <zalan>
Component: Layout and RenderingAssignee: zalan <zalan>
Status: RESOLVED FIXED    
Severity: Normal    
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
reduced test case none

Description zalan 2014-01-13 07:13:31 PST
LayoutTests/fast/forms/input-widths.html
Comment 1 zalan 2014-01-13 16:44:01 PST
Created attachment 221088 [details]
reduced test case

inline int snapSizeToPixel(LayoutUnit size, LayoutUnit location) makes the size depending on the location.
Comment 2 zalan 2014-01-13 21:30:30 PST
*** Bug 126890 has been marked as a duplicate of this bug. ***
Comment 3 zalan 2014-06-10 20:23:30 PDT
Border paint snapping fixed this http://trac.webkit.org/changeset/163272