Bug 126877

Summary: REGRESSION(r161852): Broke ToT with system Safari (Requested by kling on #webkit).
Product: WebKit Reporter: WebKit Commit Bot <commit-queue>
Component: New BugsAssignee: WebKit Commit Bot <commit-queue>
Status: RESOLVED FIXED    
Severity: Normal CC: andersca, benjamin, cmarcelo, darin, kling
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 126864    
Attachments:
Description Flags
ROLLOUT of r161852 none

Description WebKit Commit Bot 2014-01-13 02:05:03 PST
http://trac.webkit.org/changeset/161852 broke the build:
Broke ToT with system Safari (Requested by kling on #webkit).

This is an automatic bug report generated by webkitbot. If this bug
report was created because of a flaky test, please file a bug for the flaky
test (if we don't already have one on file) and dup this bug against that bug
so that we can track how often these flaky tests fail.
Comment 1 WebKit Commit Bot 2014-01-13 02:05:26 PST
Created attachment 221017 [details]
ROLLOUT of r161852

Any committer can land this patch automatically by marking it commit-queue+.  The commit-queue will build and test the patch before landing to ensure that the rollout will be successful.  This process takes approximately 15 minutes.

If you would like to land the rollout faster, you can use the following command:

  webkit-patch land-attachment ATTACHMENT_ID

where ATTACHMENT_ID is the ID of this attachment.
Comment 2 Andreas Kling 2014-01-13 02:05:46 PST
10:58:41 < abucur> kling: dyld: Symbol not found: __ZN3WTF36lockAtomicallyInitializedStaticMutexEv when calling run-safari --debug :(
10:58:57 < abucur> Referenced from: /System/Library/PrivateFrameworks/Safari.framework/Versions/A/Safari
10:58:57 < abucur>   Expected in: /Users/abucur/WebKit/WebKitBuild//Debug/JavaScriptCore.framework/Versions/A/JavaScriptCore
Comment 3 WebKit Commit Bot 2014-01-13 02:07:57 PST
Comment on attachment 221017 [details]
ROLLOUT of r161852

Clearing flags on attachment: 221017

Committed r161869: <http://trac.webkit.org/changeset/161869>
Comment 4 WebKit Commit Bot 2014-01-13 02:08:03 PST
All reviewed patches have been landed.  Closing bug.