Bug 126284

Summary: [GTK] Split WebKit2APITests/TestWebKitWebView
Product: WebKit Reporter: Carlos Garcia Campos <cgarcia>
Component: Tools / TestsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: brian.holt, commit-queue, gns, mrobinson, pnormand, zan
Priority: P2 Keywords: Gtk
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch pnormand: review+

Description Carlos Garcia Campos 2013-12-30 00:36:57 PST
WebKitWebView test is too big already making more difficult to handle timeouts and skipped tests. It could be split by moving UIClient and auth tests to their own files.
Comment 1 Carlos Garcia Campos 2013-12-30 00:41:05 PST
Created attachment 220100 [details]
Patch
Comment 2 WebKit Commit Bot 2013-12-30 00:43:13 PST
Thanks for the patch. If this patch contains new public API please make sure it follows the guidelines for new WebKit2 GTK+ API. See http://trac.webkit.org/wiki/WebKitGTK/AddingNewWebKit2API
Comment 3 Philippe Normand 2013-12-30 01:21:36 PST
Comment on attachment 220100 [details]
Patch

Nice!
Comment 4 Carlos Garcia Campos 2013-12-30 01:54:43 PST
Committed r161138: <http://trac.webkit.org/changeset/161138>
Comment 5 Brian Holt 2014-01-02 05:36:00 PST
*** Bug 120202 has been marked as a duplicate of this bug. ***