Bug 12565

Summary: ASSERTION failure on some declarative animations
Product: WebKit Reporter: Oliver Hunt <oliver>
Component: SVGAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: francisga, mitz
Priority: P1 Keywords: InRadar
Version: 420+   
Hardware: Mac   
OS: OS X 10.4   
URL: http://www.w3.org/Graphics/SVG/Test/20061213/htmlObjectHarness/full-animate-elem-36-t.html
Attachments:
Description Flags
Fix an off by one parsing error aroben: review+

Description Oliver Hunt 2007-02-04 02:03:19 PST
The above url fails on an assertion:
ASSERTION FAILED: m_type == toSVGTransform.type()
(/Users/oliver/WebKit/OpenSource/WebCore/ksvg2/svg/SVGTransformDistance.cpp:55 WebCore::SVGTransformDistance::SVGTransformDistance(const WebCore::SVGTransform&, const WebCore::SVGTransform&))
Comment 1 Maciej Stachowiak 2007-02-04 11:50:38 PST
<rdar://problem/4975132>
Comment 2 mitz 2007-02-09 07:37:25 PST
Got this assertion failure in svg/W3C-SVG-1.1/animate-elem-52-t.svg
Comment 3 mitz 2007-02-10 04:59:38 PST
Created attachment 13103 [details]
Fix an off by one parsing error

Includes change log and a manual test
Comment 4 Adam Roben (:aroben) 2007-02-10 14:12:44 PST
Comment on attachment 13103 [details]
Fix an off by one parsing error

r=me
Comment 5 David Kilzer (:ddkilzer) 2007-02-10 17:15:12 PST
Committed revision 19557.

Comment 6 David Kilzer (:ddkilzer) 2007-02-10 17:31:27 PST
*** Bug 12620 has been marked as a duplicate of this bug. ***