Bug 125436

Summary: [GTK] run-webkit-tests may DOS the system, specially in debug builds
Product: WebKit Reporter: Gustavo Noronha (kov) <gns>
Component: New BugsAssignee: Gustavo Noronha (kov) <gns>
Status: RESOLVED FIXED    
Severity: Normal CC: cgarcia, commit-queue, zan
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch for landing none

Description Gustavo Noronha (kov) 2013-12-08 20:38:59 PST
[GTK] run-webkit-tests may DOS the system, specially in debug builds
Comment 1 Gustavo Noronha (kov) 2013-12-09 01:18:22 PST
Created attachment 218735 [details]
Patch for landing
Comment 2 WebKit Commit Bot 2013-12-09 01:52:50 PST
Comment on attachment 218735 [details]
Patch for landing

Clearing flags on attachment: 218735

Committed r160304: <http://trac.webkit.org/changeset/160304>
Comment 3 WebKit Commit Bot 2013-12-09 01:52:52 PST
All reviewed patches have been landed.  Closing bug.
Comment 4 Carlos Garcia Campos 2013-12-29 06:52:06 PST
This has caused other problems unfortunately. The other day I noticed that my ephy was using the webkit library in my source tree and I hadn't run make install. I've been investigating the problem and I've noticed that my source tree is hardcoded in the rpath of the web process and plugin process executables installed in my jhbuild:

$ objdump -p /home/cgarcia/gnome/libexec/WebKitWebProcess | grep RPATH
  RPATH                /home/cgarcia/src/git/gnome/WebKit/WebKitBuild/Release/.libs:/home/cgarcia/gnome/lib64

That explains why the non installed build sources are used by my ephy instead of the installed ones. The problem is that when using --no-fast-install, the binaries are not relinked when installed. I've tried using --disable-fast-install configure option, but then it fails when trying to relink binaries not using the --no-fast-install option. 

For now I've reverted this patch locally, but maybe we can use --no-fast-install for all binaries that are going to be installed and use --disable-fast-install configure option unconditionally. Or maybe there's a way to tell libtool to not do fast-install for binaries linked with --no-fast-install ld flag. I've tried manually adding fast_install=no to the WebKitWebProcess librool wrapper script and it worked, correctly relinking the command before installing it, but I don't know if that can be done automatically somehow.

Btw, the no-fast-install ld flag was already removed by Gustavo in r116205.
Comment 5 Gustavo Noronha (kov) 2013-12-29 09:25:18 PST
Maybe we can remove the rpath instead? It's what Debian does for all binaries.
Comment 6 Carlos Garcia Campos 2013-12-29 23:28:36 PST
(In reply to comment #5)
> Maybe we can remove the rpath instead? It's what Debian does for all binaries.

If that's enough and you don't need to relink. How can we do that while installing?
Comment 7 Carlos Garcia Campos 2014-01-02 02:36:24 PST
I've tried by disabling fast install globally and the build is a lot slower :-(
Comment 8 Carlos Garcia Campos 2014-01-02 04:35:02 PST
(In reply to comment #7)
> I've tried by disabling fast install globally and the build is a lot slower :-(

Was doing it wrongly, using LT_INIT, added AC_DISABLE_FAST_INSTALL to Source/autotools/SetupLibtool.m4 and it doesn't affect to the build times, as expected.
Comment 9 Carlos Garcia Campos 2014-01-02 05:32:04 PST
See https://bugs.webkit.org/show_bug.cgi?id=126381