Bug 12474

Summary: REGRESSION(r19244): Assertion failure in layout tests: ASSERTION FAILED: loader->handle()
Product: WebKit Reporter: Mark Rowe (bdash) <mrowe>
Component: Page LoadingAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Major CC: Graham.Dennis
Priority: P1 Keywords: LayoutTestFailure, Regression
Version: 420+   
Hardware: Mac   
OS: OS X 10.4   

Description Mark Rowe (bdash) 2007-01-30 06:02:15 PST
From the buildbot output:

ASSERTION FAILED: loader->handle()
(/Users/buildbot/Desktop/BuildData/WebKit-BuildSlave/post-commit-leaks-powerpc-mac-os-x/build/WebCore/loader/loader.cpp:142 virtual void WebCore::Loader::didReceiveResponse(WebCore::SubresourceLoader*, const WebCore::ResourceResponse&))
Segmentation fault

I am seeing this locally with 100% reproducibility on editing/pasteboard/paste-RTFD.html and editing/pasteboard/paste-TIFF.html.  This has been broken since the tests were landed in r19244 as part of the fix for bug 10725.
Comment 1 Mark Rowe (bdash) 2007-01-30 06:24:27 PST
I have disabled the two tests that are causing the assertion failure so that the layout tests run to completion.  Having the layout tests busted for over 10 hours makes me nervous.
Comment 2 Graham Dennis 2007-01-30 14:45:04 PST
Fixed in r19267 by Anders.