Bug 124490

Summary: REGRESSION(r159351): It made zillion tests assert on !CF platforms
Product: WebKit Reporter: Csaba Osztrogonác <ossy>
Component: JavaScriptCoreAssignee: Csaba Osztrogonác <ossy>
Status: RESOLVED FIXED    
Severity: Normal CC: cgarcia, commit-queue, darin, ggaren, gyuyoung.kim, mhahnenberg, ossy, zan
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 123821    
Attachments:
Description Flags
Patch none

Description Csaba Osztrogonác 2013-11-18 03:10:38 PST
https://trac.webkit.org/changeset/159351

See the GTK Debug bot for details: http://build.webkit.org/builders/GTK%20Linux%2064-bit%20Debug%20WK1/builds/5414

ASSERTION FAILED: m_currentDelayedReleaseScope
../../Source/JavaScriptCore/heap/MarkedSpace.cpp(123) : void JSC::MarkedSpace::sweep()

I think it isn't a valid assertion on !CF platforms, because 
m_currentDelayedReleaseScope is only set inside CF guard.
Comment 1 Csaba Osztrogonác 2013-11-18 03:13:25 PST
I propose guarding this assertion with #if USE(CF). Patch is coming soon.
Comment 2 Csaba Osztrogonác 2013-11-18 03:18:36 PST
Created attachment 217187 [details]
Patch
Comment 3 WebKit Commit Bot 2013-11-18 08:33:00 PST
Comment on attachment 217187 [details]
Patch

Clearing flags on attachment: 217187

Committed r159423: <http://trac.webkit.org/changeset/159423>
Comment 4 WebKit Commit Bot 2013-11-18 08:33:03 PST
All reviewed patches have been landed.  Closing bug.
Comment 5 Mark Hahnenberg 2013-11-18 09:20:31 PST
(In reply to comment #2)
> Created an attachment (id=217187) [details]
> Patch

Thanks for the fix! :-)