Bug 124450

Summary: [Win] Re-enable JIT on 64-bit.
Product: WebKit Reporter: peavo
Component: JavaScriptCoreAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: achristensen, benjamin, bfulgham, cmarcelo, commit-queue, ggaren, msaboff, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: 528+ (Nightly build)   
Hardware: PC   
OS: Unspecified   
Bug Depends on: 124409, 124946, 125382    
Bug Blocks:    
Attachments:
Description Flags
Patch
none
JavaScript test results none

Description peavo 2013-11-15 23:40:19 PST
Now that bug 124409 is fixed, I suggest we re-enable JIT on 64-bit.
Comment 1 peavo 2013-11-15 23:43:10 PST
Created attachment 217119 [details]
Patch
Comment 2 Geoffrey Garen 2013-11-17 16:51:23 PST
What kind of testing did you do for this patch?
Comment 3 peavo 2013-11-18 09:44:18 PST
(In reply to comment #2)
> What kind of testing did you do for this patch?

I only tested "normal" browsing on some common sites, which seemed to work fine.
Which test(s) should I run?
Comment 4 Brent Fulgham 2013-11-18 10:11:17 PST
I assume the run-javascriptcore-tests pass with this change?
Comment 5 Geoffrey Garen 2013-11-18 10:51:36 PST
> I only tested "normal" browsing on some common sites, which seemed to work fine.
> Which test(s) should I run?

run-javascriptcore-tests and run-webkit-tests.
Comment 6 peavo 2013-11-18 12:04:39 PST
Output from run-javascriptcore-tests (no crashes):

** The following Mozilla test failures have been introduced:
        ecma/Date/15.9.5.10-1.js
        ecma/Date/15.9.5.10-10.js
        ecma/Date/15.9.5.10-11.js
        ecma/Date/15.9.5.10-12.js
        ecma/Date/15.9.5.10-13.js
        ecma/Date/15.9.5.10-2.js
        ecma/Date/15.9.5.10-3.js
        ecma/Date/15.9.5.10-4.js
        ecma/Date/15.9.5.10-5.js
        ecma/Date/15.9.5.10-6.js
        ecma/Date/15.9.5.10-7.js
        ecma/Date/15.9.5.10-8.js
        ecma/Date/15.9.5.10-9.js
        ecma/Date/15.9.5.12-1.js
        ecma/Date/15.9.5.12-2.js
        ecma/Date/15.9.5.12-3.js
        ecma/Date/15.9.5.12-4.js
        ecma/Date/15.9.5.12-5.js
        ecma/Date/15.9.5.12-6.js
        ecma/Date/15.9.5.12-7.js
        ecma/Date/15.9.5.28-1.js
        ecma/Date/15.9.5.29-1.js
        ecma/Date/15.9.5.35-1.js
        ecma/Date/15.9.5.8.js
        ecma/String/15.5.4.6-2.js

Results for Mozilla tests:
    25 regressions found.
    0 tests fixed.
Comment 7 peavo 2013-11-18 12:08:52 PST
Created attachment 217219 [details]
JavaScript test results

Attached test results.
Comment 8 Geoffrey Garen 2013-11-18 12:29:29 PST
Comment on attachment 217119 [details]
Patch

Test results don't look good.
Comment 9 peavo 2013-12-02 10:32:34 PST
Now that bug 124946 is fixed, there are no errors:

Results for Mozilla tests:
    0 regressions found.
    0 tests fixed.
    OK.
Comment 10 Brent Fulgham 2013-12-03 12:12:53 PST
Comment on attachment 217119 [details]
Patch

I don't think that 64-bit Windows will build without this enabled.
Comment 11 Brent Fulgham 2013-12-03 15:21:03 PST
(In reply to comment #10)
> (From update of attachment 217119 [details])
> I don't think that 64-bit Windows will build without this enabled.

It won't.  See https://bugs.webkit.org/show_bug.cgi?id=125186
Comment 12 Brent Fulgham 2014-04-01 10:24:01 PDT
This patch is pretty old now. Is it still usable? If not, could we rebaseline it so I can try to get it moving through review?
Comment 13 Radar WebKit Bug Importer 2014-04-01 10:24:26 PDT
<rdar://problem/16487274>
Comment 14 peavo 2014-04-01 11:34:23 PDT
(In reply to comment #12)
> This patch is pretty old now. Is it still usable? If not, could we rebaseline it so I can try to get it moving through review?

This is now a duplicate of bug 130638, since that one also enables JIT as well as LLINT.
Comment 15 peavo 2014-07-22 10:54:54 PDT

*** This bug has been marked as a duplicate of bug 130638 ***
Comment 16 Brent Fulgham 2014-10-31 11:26:17 PDT
Comment on attachment 217119 [details]
Patch

Clearing flags so this duplicate doesn't show up in the Request queue anymore.