Bug 123668

Summary: Fix UnicodeWchar after r157330.
Product: WebKit Reporter: Patrick R. Gansterer <paroga>
Component: New BugsAssignee: Patrick R. Gansterer <paroga>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue, darin
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on: 122635    
Bug Blocks:    
Attachments:
Description Flags
Patch none

Description Patrick R. Gansterer 2013-11-02 10:34:22 PDT
Fix UnicodeWchar after r157330.
Comment 1 Patrick R. Gansterer 2013-11-02 10:36:15 PDT
Created attachment 215811 [details]
Patch
Comment 2 WebKit Commit Bot 2013-11-02 10:38:52 PDT
Attachment 215811 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WTF/ChangeLog', u'Source/WTF/wtf/unicode/wchar/UnicodeWchar.cpp', u'Source/WTF/wtf/unicode/wchar/UnicodeWchar.h', u'Source/WebCore/ChangeLog', u'Source/WebCore/editing/TextIterator.cpp', u'Source/WebCore/platform/graphics/wince/FontWinCE.cpp', u'Source/WebCore/platform/graphics/wince/GraphicsContextWinCE.cpp', u'Source/WebCore/platform/text/wchar/TextBreakIteratorWchar.cpp']" exit_code: 1
Source/WTF/wtf/unicode/wchar/UnicodeWchar.h:66:  enum members should use InterCaps with an initial capital letter.  [readability/enum_casing] [4]
Source/WTF/wtf/unicode/wchar/UnicodeWchar.h:119:  More than one command on the same line  [whitespace/newline] [4]
Source/WTF/wtf/unicode/wchar/UnicodeWchar.h:119:  u_foldCase is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
Source/WTF/wtf/unicode/wchar/UnicodeWchar.h:123:  u_isprint is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
Source/WTF/wtf/unicode/wchar/UnicodeWchar.h:125:  u_isspace is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
Total errors found: 5 in 8 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Darin Adler 2013-11-02 14:19:20 PDT
Comment on attachment 215811 [details]
Patch

This looks fine. I’d like you to go further and move these functions into files with the names of the ICU header files instead of UnicodeWchar.h/cpp, and put them in a directory with some name like "FakeICU" or whatever we want to call this minimal ICU-compatible shim you are using for WinCE.

This requires changes to the WinCE build system, which is why I didn’t do it.
Comment 4 Patrick R. Gansterer 2013-11-02 14:21:11 PDT
(In reply to comment #3)
> (From update of attachment 215811 [details])
> This looks fine. I’d like you to go further and move these functions into files with the names of the ICU header files instead of UnicodeWchar.h/cpp, and put them in a directory with some name like "FakeICU" or whatever we want to call this minimal ICU-compatible shim you are using for WinCE.
> 
> This requires changes to the WinCE build system, which is why I didn’t do it.

That's exactly my plan, but I want to fix the build errors first. :-)
Comment 5 WebKit Commit Bot 2013-11-02 14:45:54 PDT
Comment on attachment 215811 [details]
Patch

Clearing flags on attachment: 215811

Committed r158499: <http://trac.webkit.org/changeset/158499>
Comment 6 WebKit Commit Bot 2013-11-02 14:45:56 PDT
All reviewed patches have been landed.  Closing bug.