Bug 123188

Summary: Add 1.0.1 and 1.0.2 webgl conformance suites to layout tests
Product: WebKit Reporter: Roger Fong <roger_fong>
Component: Tools / TestsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: dino, jonlee, kbr, roger_fong
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
patch none

Description Roger Fong 2013-10-22 17:01:43 PDT
Adding 1.0.1 and 1.0.2 webgl conformance tests to layout tests.

I've skipped known failing tests and the trunk tests for now.

I've also skipped a few unexpected failures that don't fail when running the tests via webgl-conformance-tests.html, but do when run just in a browser independently / when using run-webkit-tests.

These will need to be resolved.
Comment 1 Roger Fong 2013-10-22 17:03:41 PDT
The 1.0.1 tests also have an issue where some tests that should necessarily be in the http folder don't actually fail when run via the iframe wrapper tests.

The same tests do seem to fail as expected in the 1.0.2 tests.
Comment 2 Roger Fong 2013-10-22 17:19:31 PDT
(In reply to comment #1)
> The 1.0.1 tests also have an issue where some tests that should necessarily be in the http folder don't actually fail when run via the iframe wrapper tests.
> 
> The same tests do seem to fail as expected in the 1.0.2 tests.

Because of this, in my first patch I will only move the relevant tests from the 1.0.2 suite to the http folder.
I will not do this for the 1.0.1 tests yet because there might be an issue with having false positives here.
Comment 3 Roger Fong 2013-10-23 12:53:28 PDT
Created attachment 214983 [details]
patch
Comment 4 Roger Fong 2013-10-23 13:23:12 PDT
patch is too large to be applied because it adds about 1000 tests. 
Will not affect builds however, since that's all it does.
Comment 5 Alexey Proskuryakov 2013-10-23 23:27:12 PDT
What is the status of this bug? Looks like this landed, caused a lot of failures, and is still causing failures on bots.
Comment 6 Alexey Proskuryakov 2013-10-23 23:30:40 PDT
I marked some as failing in r157914.

Roger, please mark failing tests as failing in the future, don't skip them unless there is a specific reason to.
Comment 7 Brent Fulgham 2014-01-07 09:29:26 PST
*** Bug 94643 has been marked as a duplicate of this bug. ***
Comment 8 Brent Fulgham 2014-01-10 10:51:43 PST
*** Bug 86516 has been marked as a duplicate of this bug. ***
Comment 9 Csaba Osztrogon√°c 2014-02-13 03:44:35 PST
Comment on attachment 214983 [details]
patch

Cleared review? from attachment 214983 [details] so that this bug does not appear in http://webkit.org/pending-review.  If you would like this patch reviewed, please attach it to a new bug (or re-open this bug before marking it for review again).