Bug 120373

Summary: AX: aria-relevant does not expose AXARIARelevant
Product: WebKit Reporter: Jon Gunderson <jongund>
Component: AccessibilityAssignee: chris fleizach <cfleizach>
Status: RESOLVED FIXED    
Severity: Normal CC: aboxhall, apinheiro, cfleizach, commit-queue, dmazzoni, jcraig, jdiggs, mario, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Attachments:
Description Flags
patch none

Description Jon Gunderson 2013-08-27 13:43:09 PDT
In ARIA testcase 509 aria-relavent is not being exposed, the aria-live property should cancel the aria-presentation property
https://www.w3.org/WAI/PF/testharness/testcases/edit?testsuite_id=1&testcase_id=509 

This is an important feature for ARIA 1.0 specification to go to recommendation
Comment 1 Radar WebKit Bug Importer 2013-08-27 13:43:20 PDT
<rdar://problem/14848518>
Comment 2 James Craig 2013-09-04 13:40:06 PDT
Public test case: Previous link is to the private test harness.
https://dvcs.w3.org/hg/pfwg/raw-file/default/ARIA/1.0/tests/test-files/presentation-role/509.html
Comment 4 James Craig 2013-09-04 13:56:54 PDT
Ignore that last comment. It was intended for bug 116570.
Comment 5 chris fleizach 2013-09-05 09:03:53 PDT
Created attachment 210622 [details]
patch
Comment 6 Darin Adler 2013-09-05 18:54:27 PDT
Comment on attachment 210622 [details]
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=210622&action=review

> Source/WebCore/accessibility/AccessibilityObject.cpp:1562
> +        || hasAttribute(aria_atomicAttr)
> +        || hasAttribute(aria_busyAttr)
> +        || hasAttribute(aria_controlsAttr)
> +        || hasAttribute(aria_describedbyAttr)
> +        || hasAttribute(aria_disabledAttr)
> +        || hasAttribute(aria_haspopupAttr)
> +        || hasAttribute(aria_invalidAttr)
> +        || hasAttribute(aria_labelAttr)
> +        || hasAttribute(aria_labelledbyAttr)
> +        || hasAttribute(aria_relevantAttr);

Eventually this is going to get really slow. Every one of these is a separate hash table lookup.
Comment 7 chris fleizach 2013-09-06 08:57:44 PDT
(In reply to comment #6)
> (From update of attachment 210622 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=210622&action=review
> 
> > Source/WebCore/accessibility/AccessibilityObject.cpp:1562
> > +        || hasAttribute(aria_atomicAttr)
> > +        || hasAttribute(aria_busyAttr)
> > +        || hasAttribute(aria_controlsAttr)
> > +        || hasAttribute(aria_describedbyAttr)
> > +        || hasAttribute(aria_disabledAttr)
> > +        || hasAttribute(aria_haspopupAttr)
> > +        || hasAttribute(aria_invalidAttr)
> > +        || hasAttribute(aria_labelAttr)
> > +        || hasAttribute(aria_labelledbyAttr)
> > +        || hasAttribute(aria_relevantAttr);
> 
> Eventually this is going to get really slow. Every one of these is a separate hash table lookup.

Do you think we should cache this result? Or do you know of another way to check for the presence of a list of attributes?

Thanks
Comment 8 WebKit Commit Bot 2013-09-06 09:12:50 PDT
Comment on attachment 210622 [details]
patch

Clearing flags on attachment: 210622

Committed r155191: <http://trac.webkit.org/changeset/155191>
Comment 9 WebKit Commit Bot 2013-09-06 09:12:52 PDT
All reviewed patches have been landed.  Closing bug.