Bug 120252

Summary: REGRESSION(r154545): Broke WebKit2 API tests (Requested by andersca on #webkit).
Product: WebKit Reporter: WebKit Commit Bot <commit-queue>
Component: New BugsAssignee: WebKit Commit Bot <commit-queue>
Status: RESOLVED FIXED    
Severity: Normal CC: andersca, cgarcia, zan
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 103377    
Attachments:
Description Flags
ROLLOUT of r154545 none

Description WebKit Commit Bot 2013-08-24 12:58:28 PDT
http://trac.webkit.org/changeset/154545 broke the build:
Broke WebKit2 API tests (Requested by andersca on #webkit).

This is an automatic bug report generated by the sheriff-bot. If this bug
report was created because of a flaky test, please file a bug for the flaky
test (if we don't already have one on file) and dup this bug against that bug
so that we can track how often these flaky tests case pain.

"Only you can prevent forest fires." -- Smokey the Bear
Comment 1 WebKit Commit Bot 2013-08-24 12:58:51 PDT
Created attachment 209552 [details]
ROLLOUT of r154545

Any committer can land this patch automatically by marking it commit-queue+.  The commit-queue will build and test the patch before landing to ensure that the rollout will be successful.  This process takes approximately 15 minutes.

If you would like to land the rollout faster, you can use the following command:

  webkit-patch land-attachment ATTACHMENT_ID

where ATTACHMENT_ID is the ID of this attachment.
Comment 2 WebKit Commit Bot 2013-08-24 13:03:07 PDT
Comment on attachment 209552 [details]
ROLLOUT of r154545

Clearing flags on attachment: 209552

Committed r154551: <http://trac.webkit.org/changeset/154551>
Comment 3 WebKit Commit Bot 2013-08-24 13:03:10 PDT
All reviewed patches have been landed.  Closing bug.
Comment 5 Carlos Garcia Campos 2013-08-25 01:34:12 PDT
I'm very surprised that r154545 affects C API unit tests, because this code is GTK+ specific and only runs from a WebExtension, and no extension is loaded when running C API tests.
Comment 6 Carlos Garcia Campos 2013-08-25 01:36:23 PDT
(In reply to comment #4)
> I'm seeing unit test regressions in debug AppleMac builds, but due to r154540, not 154545. Could you please double-check?
> 
> http://build.webkit.org/builders/Apple%20Lion%20Debug%20WK1%20%28Tests%29?numbuilds=25
> http://build.webkit.org/builders/Apple%20Lion%20Debug%20WK2%20%28Tests%29?numbuilds=25
> http://build.webkit.org/builders/Apple%20MountainLion%20Debug%20WK1%20%28Tests%29?numbuilds=25
> http://build.webkit.org/builders/Apple%20MountainLion%20Debug%20WK2%20%28Tests%29?numbuilds=25

hmm, r154540 does affect the C API, it only adds a new callback to the page loader client, though. In any case, r154545 depends on r154540, so both would need to be rolled out in case the regression is actually caused by r154540.
Comment 7 Carlos Garcia Campos 2013-08-25 02:15:41 PDT
It seems to me that the offsets used in APIClientTraits<WKBundlePageLoaderClient> are wrong, and I also added the wrong offset too in r154540
Comment 8 Carlos Garcia Campos 2013-08-25 02:24:24 PDT
See https://bugs.webkit.org/show_bug.cgi?id=120268