Bug 119804

Summary: Win64 needs std::isnan
Product: WebKit Reporter: Alex Christensen <achristensen>
Component: JavaScriptCoreAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: eflews.bot, gyuyoung.kim, msaboff
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch msaboff: review+, eflews.bot: commit-queue-

Description Alex Christensen 2013-08-14 10:39:47 PDT
There is one place in JavaScriptCore/offlineasm/cloop.rb that appears to have been forgotten in https://bugs.webkit.org/show_bug.cgi?id=109325 and it needs std:: before isnan to compile on Win64 with the jit disabled.
Comment 1 Alex Christensen 2013-08-14 10:40:24 PDT
Created attachment 208742 [details]
Patch
Comment 2 EFL EWS Bot 2013-08-14 12:21:18 PDT
Comment on attachment 208742 [details]
Patch

Attachment 208742 [details] did not pass efl-wk2-ews (efl-wk2):
Output: http://webkit-queues.appspot.com/results/1452903
Comment 3 Alex Christensen 2013-08-14 13:05:24 PDT
(In reply to comment #2)
> (From update of attachment 208742 [details])
> Attachment 208742 [details] did not pass efl-wk2-ews (efl-wk2):
> Output: http://webkit-queues.appspot.com/results/1452903

I don't think this was caused by my patch.  I'm going to commit the patch manually.
Comment 4 Alex Christensen 2013-08-14 13:15:49 PDT
r154066