Bug 118348

Summary: Name resources related to snapshotted plug-ins more accurately
Product: WebKit Reporter: Antoine Quint <graouts>
Component: Plug-insAssignee: Antoine Quint <graouts>
Status: RESOLVED WONTFIX    
Severity: Normal CC: buildbot, commit-queue, dino, eflews.bot, esprehn+autocc, glenn, gtk-ews, gyuyoung.kim, macpherson, menard, rakuco, rego+ews, rniwa, webkit-ews, xan.lopez, zan
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch dino: review-, buildbot: commit-queue-

Antoine Quint
Reported 2013-07-03 03:02:36 PDT
To support https://bugs.webkit.org/show_bug.cgi?id=118347, we'll add a new CSS file to style the content of the missing/blocked plug-in content. Since we'll want to load this CSS file independently of any CSS file related to snapshotted plug-ins, we need to rename the plugIns.css and plugIns.js files to have less of a generic name.
Attachments
Patch (32.52 KB, patch)
2013-07-03 03:04 PDT, Antoine Quint
dino: review-
buildbot: commit-queue-
Antoine Quint
Comment 1 2013-07-03 03:04:54 PDT
Build Bot
Comment 2 2013-07-03 03:10:22 PDT
Early Warning System Bot
Comment 3 2013-07-03 03:12:28 PDT
Early Warning System Bot
Comment 4 2013-07-03 03:13:12 PDT
EFL EWS Bot
Comment 5 2013-07-03 03:18:29 PDT
EFL EWS Bot
Comment 6 2013-07-03 03:20:18 PDT
Build Bot
Comment 7 2013-07-03 03:24:50 PDT
kov's GTK+ EWS bot
Comment 8 2013-07-03 04:01:17 PDT
Dean Jackson
Comment 9 2013-07-03 04:25:46 PDT
Comment on attachment 205989 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=205989&action=review > Source/WebCore/ChangeLog:27 > + (object::-webkit-snapshotted-plugin-content): > + (object::-webkit-snapshotted-plugin-content > .snapshot-overlay): > + (object::-webkit-snapshotted-plugin-content > .snapshot-overlay > .snapshot-label): > + (object::-webkit-snapshotted-plugin-content > .snapshot-overlay > .snapshot-label > div): > + (object::-webkit-snapshotted-plugin-content > .snapshot-overlay > .snapshot-label > .snapshot-title): > + (object::-webkit-snapshotted-plugin-content > .snapshot-overlay > .snapshot-label > .snapshot-subtitle): No need for all this if it is just a rename. > Source/WebCore/WebCore.xcodeproj/project.pbxproj:8082 > + 5A91469E8E9F8485C37A2876 /* JSSVGGraphicsElement.cpp */ = {isa = PBXFileReference; fileEncoding = 30; lastKnownFileType = sourcecode.cpp.cpp; path = JSSVGGraphicsElement.cpp; sourceTree = "<group>"; }; This is just Xcode screwing around with the file, but I generally remove these changes by hand. > Source/WebCore/WebCore.xcodeproj/project.pbxproj:9367 > + 950C4C02BED8936F818E2F99 /* JSSVGGraphicsElement.h */ = {isa = PBXFileReference; fileEncoding = 30; lastKnownFileType = sourcecode.c.h; path = JSSVGGraphicsElement.h; sourceTree = "<group>"; }; Same. > Source/WebCore/WebCore.xcodeproj/project.pbxproj:-11071 > - 5A91469E8E9F8485C37A2876 /* JSSVGGraphicsElement.cpp */ = {isa = PBXFileReference; fileEncoding = 30; lastKnownFileType = sourcecode.cpp.cpp; path = JSSVGGraphicsElement.cpp; sourceTree = "<group>"; }; > - 950C4C02BED8936F818E2F99 /* JSSVGGraphicsElement.h */ = {isa = PBXFileReference; fileEncoding = 30; lastKnownFileType = sourcecode.c.h; path = JSSVGGraphicsElement.h; sourceTree = "<group>"; }; And here's where they came from. > Source/WebCore/css/CSSDefaultStyleSheets.cpp:208 > - plugInsRules = String(plugInsUserAgentStyleSheet, sizeof(plugInsUserAgentStyleSheet)); > + plugInsRules = String(snapshottedPlugInsUserAgentStyleSheet, sizeof(snapshottedPlugInsUserAgentStyleSheet)); This is where the change of name doesn't look right. I'm not sure if this is where you're intending to load the blockedPlugins.css, but if not, then I think you should just leave plugins.css named as it is. Otherwise plugInsRules has a generic name for what it is. > Source/WebCore/rendering/RenderTheme.h:92 > - // adjust the default CSS rules in html.css, quirks.css, mediaControls.css, or plugIns.css > + // adjust the default CSS rules in html.css, quirks.css, mediaControls.css, or snapshottedPlugIns.css > virtual String extraDefaultStyleSheet() { return String(); } > virtual String extraQuirksStyleSheet() { return String(); } > virtual String extraPlugInsStyleSheet() { return String(); } It's now a bit weird that the method name is fairly different from the file it is replacing.
Dean Jackson
Comment 10 2013-07-03 04:28:41 PDT
Comment on attachment 205989 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=205989&action=review > Source/WebCore/ChangeLog:14 > + * Resources/snapshottedPlugIns.js: Renamed from Source/WebCore/Resources/plugIns.js. This breaks compilation in Document.cpp.
Dean Jackson
Comment 11 2013-07-03 04:29:57 PDT
Source/WebCore/dom/Document.cpp:6011:20: error: use of undeclared identifier 'plugInsJavaScript' jsString = plugInsJavaScript; ^ 1 error generated.
Antoine Quint
Comment 12 2013-07-03 05:00:54 PDT
Yeah, I think we might as well just keep plugIns.css and plugIns.js and have an extra unavailablePlugIns.css to complement it.
Note You need to log in before you can comment on or make changes to this bug.